Yellow Bullet Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
I have a 355 ,that was just put on a dyno,showing 300 hp at the wheels.I'm running a 750 dominator,that apd installed there pro-series conversion kit.The jets in primary are 74's that came with carb as factory set-up,the secondary's have 82's.The power valve in front only is a 4.5.The accelerator jet/nozzle are 28 in both.First time out at local track car ran 12.79,after the 3rd run, I quicken to a 12.69,but around a 1000 feet,now my hearing is not great due to an accident,but anyway,it feels like its surging or maybe leaning out??So that was the last run for that track,I go to track next night and with no changes,I run a [email protected],doing the exact thing,around a 1000 feet or so,it starts that surging,but still pulling,due to ran 105.51 the last run the night before.So when it was dyno,tuner said might have to put larger accelerator pump nozzle to like 31's,or should I just jet up secondary's to 83's or 84's before that change,then run it,to see if that works,I'm running 110 fuel with magnafuel fuel pump in rear with fuel tank in rear trunk.any suggestions,I thank you.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #3 ·
Thanks,for reply.I made one when I first put carb. from apd on.I was running kn 360 degree air cleaner that was crushing tube down when tightening air cleaner bolt,since dyno testing,realizing,without air cleaner,I have 9 extra horsepower.Also put a call in with john at apd,waiting on any suggetions,but without aircleaner,I can install piece without issues,to see if that solves an issue.
 
1 - 3 of 3 Posts
Top