Yellow Bullet Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
376 Posts
Discussion Starter · #1 ·
I have a turbo 400 with an aluminum drum, 300m input shaft in a stock case. I have roughly 200 miles since having this thing built. At first when running it sounded like a noisy convertor or a small clunk on revolutions. The last time I started it it had a screeching/ screaming noise coming from the pump area getting louder with rpm to move. I pulled it out and pulled it apart. Found metallic brass looking in the oil and noticed my stator tube bushing are shot. What would cause this? Thanks for all of the help. Gonna attempt to fix this on my own.
7C5CE027-0F40-4792-AE4C-A60F8044DDC8.jpeg
F232510B-5523-438C-83A8-35FC14E96146.jpeg
6023E8AE-98D8-49F8-940D-CCC5489E453D.jpeg
7C5CE027-0F40-4792-AE4C-A60F8044DDC8.jpeg
F232510B-5523-438C-83A8-35FC14E96146.jpeg
 

·
Super Moderator
Joined
·
19,817 Posts
The bushing looks a bit beat up but as already stated, the converter should have its own support bushing and the front tube bushing doesn't look destroyed enough to make a mess of your oil so keep looking.


Hutch
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #5 ·

·
Registered
Joined
·
376 Posts
Discussion Starter · #7 ·
She’s apart. Everything looks good other than the pump bushings. Can definitely tell it only has 200-300 miles on it.
264522
264524
264525
78C15742-1C17-4225-9D3A-66A1D0F32912.jpeg
D1DE1FA3-D829-489F-9F3F-6CB56FC20C87.jpeg
773E6D02-9086-44E1-BF8E-10BF602D9721.jpeg
 

·
Registered
Joined
·
1,642 Posts

·
Registered
Joined
·
376 Posts
Discussion Starter · #9 ·
Convertor just got sent back. Does anything in the pictures look bad?
 

·
Registered
Joined
·
818 Posts
It's hard to tell when you don't have everything apart. As Hutch mentioned, the debris in the picture you posted in your other thread came from somewhere. You should continue to disassemble the whole thing. I'd be curious as to what the pump looks like after all of that debris went through it.
 
1 - 12 of 12 Posts
Top