Yellow Bullet Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
my t400 high gear clutches are glazing and the steels have hot spots on them. every thing else looks perfect. the clearance on high is .075 do you think that is not enough clearance? its a 9.50 car
 

·
Registered
Joined
·
144 Posts
what RPM u running? has the drum been drilled for high RPM app? more info will help...
how the 2/3 shift? what line pressure? run a mod.? what rings u got on center support?



Roger
 

·
Super Moderator
Joined
·
19,379 Posts
my t400 high gear clutches are glazing and the steels have hot spots on them. every thing else looks perfect. the clearance on high is .075 do you think that is not enough clearance? its a 9.50 car

Is this a transbrake application? What mods other than clutch clearance have you done? Whats the rear gear ratio?


Hutch
 

·
Registered
Joined
·
152 Posts
Discussion Starter #4
I have a .060 hole in the drum , it is a trans brake car, i do have teflon sealing rings on the center support the second from the top ring has been removed and also the lip seal in the drum is removed.i shift the car at 7000 with a 4.56 rear gear. i am not sure of the line pressure but it does have a high pressure spring in the pump with no horse shoe shims
 

·
Super Moderator
Joined
·
19,379 Posts
I have a .060 hole in the drum , it is a trans brake car, i do have teflon sealing rings on the center support the second from the top ring has been removed and also the lip seal in the drum is removed.i shift the car at 7000 with a 4.56 rear gear. i am not sure of the line pressure but it does have a high pressure spring in the pump with no horse shoe shims
Did you also install an evil set of return springs or just stock ones? What valve body is it?


Hutch
 
1 - 6 of 6 Posts
Top