Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1 (Edited)
Got a question. I have a 598 12° Reher-Morrison naturally aspirated and my normal fuel of choice is Sunoco maximal and I went to run this weekend and had to use C16 because I was out of Sunoco. Note car did sit 2 months. Car stumbled at the hit and ran great out the back end. Couple times car died. Went back to pits turned idle screws out and stumbled and turned them in and stumbled the same. Pulled metering blocks off and blowed out airbleeds and circuits and no help. Checked squirters and they are all working great and float levels are correct. Next pass I idled car up more in the beams still stumbled but a little less but still smokes like a freight train. Any idea if the fuel I’m using could be the culprit or what should I check now? Never experienced this problem except when I ran in 40 degree weather and operating temperature wasn’t met
 

·
Registered
Joined
·
543 Posts
Almost sounds like one of the needle and seats is a issue.Flooding fuel out vent tube.There is weight diff in max and c16.But I can't imagine jetting being that far off between two unless you already way fat on max tune.C16 would need less jetting yet
 

·
Long Live The King
Joined
·
98,095 Posts
Compression of engine and RPM ?
 

·
Registered
Joined
·
84 Posts
Discussion Starter #10
I figured it out. Ended up being accelerator springs needing adjusting because they had a bunch of slack in springs and one of the roll pins on accelerator arm was backing out. Back to normal now. Thanks everyone for the input
 

·
Registered
Joined
·
818 Posts
Is anyone using e85 in NA applications?
I ran my engine on the dyno on sunoco e-85r and 112.
It made 15 more horsepower on 112 but about 5-7 ftlb less torque.
 
1 - 13 of 13 Posts
Top