Yellow Bullet Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
How much timing are you guys getiing away with on 93 octane?

Combo:
502 bbc efi procharged 10 psi, 8.75 static compression, rhs rect alum head
cam specs 587 610 288 298
 

·
Registered
Joined
·
349 Posts
355 chevy
brodix rr200 heads
roller cam
10.3 static compression
11 psi boost with intercooler
30 degrees total with a 11.5 a:f ratio on 93 sunoco
 

·
Moderater
Joined
·
13,467 Posts
How much timing are you guys getiing away with on 93 octane?

Combo:
502 bbc efi procharged 10 psi, 8.75 static compression, rhs rect alum head
cam specs 587 610 288 298

With the 8.75 compression and minimum duration cam I would start at 24* Do you have a way to retard the timing or are you locking it??
 

·
Registered
Joined
·
49,769 Posts
what head and style of piston are you using ? makes a big difference in timing requirements.
 

·
Registered
Joined
·
832 Posts
Oh and a to a intercooled


looks like Im way safe on my setup
I would agree. If you are intercooled and with that CR you should be fine. I run 9.3:1, water/meth and 34*.

EFI won't let you run quite as much as blow thru but you should be fine. How does the strap look on your plugs?
 

·
Registered
Joined
·
349 Posts
cam and head combo have alot to do with it like collins said. i have a flat top piston and a high compression and a large cam for a small block and i run alot of timing. started at 24 total and kept going up a degree at a time and the car kept responding. I run EFI on mine not a blow through.
 

·
Registered
Joined
·
49,769 Posts
Dished,flat, chamber size ? quench ? all make a difference. Whats the plug looking like. It is the only Eye witness we get.

Rhs alum heads and JE forged pistons
 

·
Registered
Joined
·
49,769 Posts
Has that plug seen idle time ? If not that doesn;t look good.
 

·
Registered
Joined
·
712 Posts
get the meth kit back,
snow performance stage II or get the AIS system.

My plugs are much blacker, probably because my afr is pick rich.
I'd like to see some plugs with meth injection added in the mixture. I'm not sure if they will make them cleaner or wont effect the look.
 

·
Registered
Joined
·
49,769 Posts
Better pull that motor down and check the slugs and make sure you didn;t pinch up a ring land. Pump fuel and boost on a big block is a bad recipe. the big ass chambers are just to unstable for good consistent tunning.

What kind of ECU problems were you having ?

I had major tuning issues witha bad ecu so thats why the plugs looks crusty oil on them. My main consern was seeing any pepper on the porcelain.

AF now is about 11.3 on WOT
 

·
Registered
Joined
·
46 Posts
Discussion Starter #19
Better pull that motor down and check the slugs and make sure you didn;t pinch up a ring land. Pump fuel and boost on a big block is a bad recipe. the big ass chambers are just to unstable for good consistent tunning.

What kind of ECU problems were you having ?
I was dealing with Arizona Speed and Marine w there tuning software and they had some stuff locked on the back side that i could not get to. The car constantly came in and out of limp mode and every one was pointing there fingers and some one else. Long story short this went on for over a year and desided to switch to the MSD/Painless wiring software. (same as what asm was using just rebranded) bought a new ecu through them since( had 2 go bad through ASM) and now all is good. I still to this day do not know what he had done on the back side to make it run like that.

Why would I tear my engine down? Car is running good now. The plugs look like that because of all the tuning issues that I was having. Ill put new plugs in a post more pics later.
 

·
Registered
Joined
·
49,769 Posts
there is sulfur ash on the plugs. a sure sign the engine is consuming oil. You have to really detonate a motor pretty hard to get it to do that. Generally if the detonation is light and not very servre the engine gets out ok. Pump fuel though can really become quiet a disaster however when it gets angry and becuase of its relatively high flame speed and break parts in ways you never knew.

get us some fresh plug pics. Maybe she did make it out ok. I doubt it though.

The only thing I buy from ASM are throttle bodys and parts. same thing with TPIS.

I was dealing with Arizona Speed and Marine w there tuning software and they had some stuff locked on the back side that i could not get to. The car constantly came in and out of limp mode and every one was pointing there fingers and some one else. Long story short this went on for over a year and desided to switch to the MSD/Painless wiring software. (same as what asm was using just rebranded) bought a new ecu through them since( had 2 go bad through ASM) and now all is good. I still to this day do not know what he had done on the back side to make it run like that.

Why would I tear my engine down? Car is running good now. The plugs look like that because of all the tuning issues that I was having. Ill put new plugs in a post more pics later.
 
1 - 20 of 21 Posts
Top