Yellow Bullet Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
1,793 Posts
Discussion Starter #1
I have limited data as of right now, but I have a little....

My second system comes on and seems to be resetting my progressive. I have 2 systems, both run through an NOS Launcher. It seems to be gradually getting worse. The first time it showed itself, we assumed that I lifted, and therefor reset the progressive. 5 or 6 passes later, I have narrowed it down that something is happening when the second system comes on. It does it every pass now, and the progressive restarts itself almost as soon as the second system comes on. The first time it happened, it reset after the second system was on for a few tenths. When everything was new, it didn't do it at all.....has gotten worse and worse.

I only have 20-25 passes total, so this has happened in a short period of time.

Anybody ever ran into this?
 

·
Registered
Joined
·
2,410 Posts
I would look into your ground, seems like as the second system comes on, the launcher ground load becomes higher, one systems may only need 20 amps and as soon as the second comes on it requires maybe double( not sure what your using for noids) so if your ground connection is getting worse it makes sence why it is doing it more offen. and because it is so week under load your progressive controller resets it self.
 

·
Registered
Joined
·
1,793 Posts
Discussion Starter #5
I would look into your ground, seems like as the second system comes on, the launcher ground load becomes higher, one systems may only need 20 amps and as soon as the second comes on it requires maybe double( not sure what your using for noids) so if your ground connection is getting worse it makes sence why it is doing it more offen. and because it is so week under load your progressive controller resets it self.
It does seem like the load is the problem, you might be correct.
 

·
Registered
Joined
·
3,062 Posts
I am talking about the ground from the launcher the big thick black one.
Yes I thought you were... I was wondering if he is running a floating ground system... IMO very critical on a nitrous car with a progressive
 

·
Registered
Joined
·
675 Posts
Pull up your runs on the msd along with the trace box, and scroll through the run watching the launch to make sure you don't have a bad trans brake button. I've seen that happen on about 10-12 cars over the past 3yrs., the first one kicked my ass trying to find the problem. It don't take but a little glinch....
 

·
Registered
Joined
·
1,793 Posts
Discussion Starter #12
Pull up your runs on the msd along with the trace box, and scroll through the run watching the launch to make sure you don't have a bad trans brake button. I've seen that happen on about 10-12 cars over the past 3yrs., the first one kicked my ass trying to find the problem. It don't take but a little glinch....

Checked it, not it. Great suggestion though.
 

·
TRZ Rocks!
Joined
·
3,737 Posts
Is the activation wire that controls the retard in the MSD going thru the Progressive (i.e. the pregressive creates the signal) or is it hooked up so that the activation wire on the progressive also goes to the msd retard?
 

·
Registered
Joined
·
1,793 Posts
Discussion Starter #14
The launcher sends the signal to the MSD for the retards through it's GPO's (General Purpose Outputs)
 

·
Registered
Joined
·
6,389 Posts
does it only do it during a pass or will it do it while dry testing it in the shop with the car not running ?

jay
 

·
Registered
Joined
·
1,793 Posts
Discussion Starter #17
Only does it going down the track.
Microswitch has been replaced twice, but I don't think it's that anyway because it only does it when the second system comes on.
 

·
Registered
Joined
·
8,135 Posts
2 foggers?
Had a issue long ago where the progressor could not handle the amp draw of the 8 noids. (esp. if you have high amp noids)
Only way we found it was to uhhook progressor and it ran perfect.... havent used one since.
 

·
Registered
Joined
·
6,389 Posts
the way i wire our progressives, I always come out of the progressive and go to constant duty solenoids before going to the nitrous/fuel solenoids... i have never gone direct from the progressive to the nitrous/fuel solenoids.... for the very reason listed by atv racer.. i understand these things say they can handle the load, but i'd rather not hope it will ...

your other route is ditch the progressive and split the foggers into "4" systems going bank to bank, but even though alot of fast guys are doing this, there still alot of guys who dont like it...

or play with gear/launch retards to get the car rolling...


call up monte smith and see if he can give you any input on your issue since you have a nos launcher.. he's always helped us even when we had'nt bought any thing from him...


jay
 
1 - 20 of 29 Posts
Top