Yellow Bullet Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
864 Posts
Discussion Starter #1
heres the setup...lq9 longblock, ls6 cam, s475 turbo, 15-16 degrees of timing

last year had the truck intake on it and at 5500 rpm the power would just level off and stay flat

now with the edelbrock pro-flo, after 5500 rpm the power just falls off hard...no knock, no valve float

we know the intake isnt a restriction lol, and the ls6 cam def. rev's higher than 5500

So what could be causing this/fix this
 

·
out of work hair dresser
Joined
·
8,341 Posts
What does the rest of the combo include?
 

·
Registered
Joined
·
864 Posts
Discussion Starter #5
And yes I know duals would be much better but I'm waiting to do that when I change cams, but the yellows are still not floating
 

·
out of work hair dresser
Joined
·
8,341 Posts
Down pipe size, open or full exhaust, stock push rods? FMIC? etc, etc, etc.
 

·
LSXTTFMF
Joined
·
927 Posts
They may not be floating but they may not be fully seating either. With boost you have to take into consideration seat pressure is reduced when there is pressure on the back side of the valve pushing back against it.
 

·
Registered
Joined
·
864 Posts
Discussion Starter #8
4in down pipe with a bullet muffler and exh ends under rear seats...a2w intercooler with iat's only 5-10 above ambient...cm 7.4 pushrods
 

·
Registered
Joined
·
864 Posts
Discussion Starter #9
Even with the truck intake, when the power flattened off at 5500 on the road/ track it would not lose power, just kept pulling just as strong
 

·
Registered
Joined
·
3,088 Posts
Simple. Put truck intake back on :) Easy to do though. It should peak there with Truck intake. the pro flo, not sure, does it just suck?

yellow springs and ls6 cam might be ok on a oem deal, but under a 475, at least get a 1218 or something on it. THeres a new beehive still works with stock retainer thats lighter and you can set it up with about 30-40 more lounds on the seat than you have now easy.


How do you KNOW its not valve float and no chance the springs have just wore out
 

·
Registered
Joined
·
1,081 Posts
I have made 747 to the tires with ls6 springs in a 6l GTO with a stock cam. This was with a 372 Bullseye turbo @19psi. We later changed to duals with the 374 with a race cover and made 825rwhp with that unit. Both times it peaked at 5400rpm with the stock LS2 intake and 90mm TB.

We made 681rwhp through 35" tires on a Silverado with a 5.3l and a LS6 cam. This one peaked at 5400ish too, here is a dyno graph with three LS6 turbo dynos with good valve springs.

 

·
Registered
Joined
·
864 Posts
Discussion Starter #12
well the pro flo does suck, but in a good way lol, it flows alot more air and isnt a restriction so its staying. I figured the ls6 yellows would be enough for my lower boost cause i knew of hellbent, cobrakiller, and a few others running alot more boost than me on the same springs, but yes stiffer springs could be better

so, is it the ls6 cam that is peaking? i thought they pulled to 6k but from helbents vehicles it sounds like its the cam
 

·
Registered
Joined
·
864 Posts
Discussion Starter #14
On NA vehicles they will carry ok to 6 but will not peak there. Every turbo charged one I have tuned peaks before 5600.
well thanks man, i guess thats my problem then, everything else checked out ok....time to order a turbo cam, springs, and head studs now
 
1 - 14 of 14 Posts
Top