Yellow Bullet Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
458 Posts
Discussion Starter #1
Any one running a plenum system such as a Viper or Otzel had problems with the nylon lock nuts backing off??
 

·
Registered
Joined
·
2,340 Posts
The nuts on the allen bolts holding the kits into the front and rear of the plenum.
If your shit wasn't old and junky, the intake would be threaded and you wouldn't need nuts. I guess you not having nuts is like 90% of the problem anyway.

Just kidding- Steve, don't send me a mean message. This dude is a friend/ customer of mine. I can be crappy to him- he deserves it!!
 

·
First round fodder...
Joined
·
3,602 Posts
no but if your worried about it use fresh nuts anytime you pull it apart.
 

·
Registered
Joined
·
458 Posts
Discussion Starter #7
If your shit wasn't old and junky, the intake would be threaded and you wouldn't need nuts. I guess you not having nuts is like 90% of the problem anyway.

Just kidding- Steve, don't send me a mean message. This dude is a friend/ customer of mine. I can be crappy to him- he deserves it!!
Dang I take this kind of abuse on the phone all the time...now on the internet??? ..

I know all my shit is ancient but the kits are newer...I had the problem with the engine in the car now so I went and checked the intake off the 811 and some are loose on it also.

Im not trying to say anything bad Im just wondering if its a common deal. Maybe Billys tune ups are just that badass
 

·
Registered
Joined
·
414 Posts
All of the Speedtech's internal systems the front of the manifold are tapped. All the ones were are doing now are a little different but still use no nuts.
 
1 - 8 of 8 Posts
Top