Yellow Bullet Forums banner
1 - 7 of 7 Posts

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #1 ·
Dammit - title should be ONE FUEL SYSTEM WITH DEADHEAD REGULATORS - ISSUE.
I hate that you can't edit that. :(

I previously ran the engine on one fuel system and the nitrous on another (it's own pump). Both systems are deadhead (no return) with no air bleeds either. To minimize creep, I always turned the nitrous fuel pump on right before I prestaged.

Now, I've combined them into one system (-10 line) off one pump (BG400) and I have a fuel log at the front with the engine regulator and the nitrous regulator. Both are still deadheaded.

I have no issues with the engine side, but I had not thought about the fact that I now have fuel pressure on the fuel solenoids and no where for it to go. I went for a short drive the other day and even though I have the nitrous FP regulator set around 7 psi, I was getting over 10 psi and climbing during the short drive.

I'm guessing pressure will drop quickly when I spray it and the solenoids open, but I'm worried about that much fuel on the hit plus much much is too much on teh solenoids? I don't want them to leak or anything when running N/A or on teh motor.

Running 20 psi at the fuel pump (it has a bypass built in).

Do I need to run bleeds before the fuel 'noids or do I need a bypass regulator or ???

Thanks.

 

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #4 ·
Depend on who you talk to, or listen to...
Some run bleeds, some dont..... I always do....
Jump in here newlywed [Steve] and tell him why you dont...
Maddawg
That's what I've always understood as well. I've read a lot of those different theories as well. It depends more on how the tuner likes to do things and being consistent with the tune is the key.

But I'm not worried so much about it creeping a pound or two when staging, I'm concerned about excessively high pressure when driving or running N/A.

Going to run it on the motor this thursday and will see how that goes. Will be spraying it soon after.
 

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #5 ·
Bump?

Just putting it up on the trailer tonight, It got to 15 psi on the nitrous fuel pressure gauge. It died instantly soon after that. I'm wondering if fuel is pushing past the noids? They sat for a bout 3 years - probably killed them? or no?
 

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #8 ·
Duh, thanks, Mitch. been working too hard/long lately and my brain isn't even picking up on the easy stuff.

Let me go back to pounding it in the wall for a while.... :D
 

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #11 ·
Thanks all.

Steve, it is a Holley regulator that was on the car when I got it. I looked all over for a part number and there isn't one, but it looks just like the 12-803 and knowing that the previous owner probably got it at BB&T and that's what they have there, I'm sure it's what it is.

Since the regulator isn't "rated" for pressures that high, I wasn't sure if it would be a problem or not. I also noticed that if I bump the pump off for a split second (of course the pressure goes to near 0) but then it recovers to around 6 or 7 psi where it is set before slowly creeping up again

I plugged the lines and capped the regulator last time out since I was just making motor passes but I'm going to hook them back up and check it like Mitch suggested. I found why it was so rich also, so now I don't think they are leaking away.

Thanks.
 

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #15 ·
I have the same set-up ( dead head holley reg, plate, and bg400) with no issues at all. And I drive the car on the street every week.
And your fuel pressure at the 'noids sky rockets as well?
 

·
...failure to communicate
Joined
·
4,872 Posts
Discussion Starter · #20 ·
Thanks everyone.

Steve, not sure which picture you are looking at, but it's likely not set. After my fuel pump got fixed, the BG regulator decided to die on me. I also had a dead gauge. I plugged the BG regulator (carb) and the nitrous fuel lines and used the Holley for the carb temporarily to get it running.

That's when I found the gauge was flaky as well. that's probably why the setting was off. Not sure when i took the pic. replaced the BG with an aeromotive and capped the Holley for some motor pulls. Going out tomorrow night and if the motor passes are clean, I'm going to hook the nitrous fuel back up and set the flowing pressure and spray it.

I'll let you know how the reg works out - thanks for all the tips!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top