Yellow Bullet Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
818 Posts
Discussion Starter #1
I got a friend who has been having problems with his nos all year. It's a NX kit and nothing has been changed from last year.With a 175 shot he would go from 10.3's to 9.7's now when he hits it for a split second it works then starts sputtering. I don't have all the details but thought you guys might know where to start looking. He has drained the bottles and refilled with fresh Nos with the same thing happening.
Like I said nothing has changed from last year and all the electrical seems to fine. He's gone up and down with the timing retard and played with the jets a little to richen and lean out slightly with the same results.
What do you guys suggest to check or try?I will try and get more details today on anything else he has changed or tried as well.
 

·
Super Moderator
Joined
·
9,240 Posts
Hard to tell. Check all the electrical connections and check the lines and solenoids to see if there's any junk in them.
 

·
Administrator
Joined
·
136,626 Posts
Remove the inline fittings at the solenoid that have a filter screen in them and clean them out. Also check the fuel filter and clean it out. Is the regulator still OK?
 

·
Registered
Joined
·
4,950 Posts
Clean the air bleeds if this is a carb car. We had the same problem a few years back replaced pulgs, wires, etc before we finally found what it was. also had some issues with not getting enough air to the carb caused it to do the samething.
 

·
Registered
Joined
·
10,720 Posts
I know NOS used screens in the inlet fitting of the N2O and I have experienced these getting clogged and causing what you are describing. Take the fittings off and inspect them for debris as Jim recommended.
 

·
Registered
Joined
·
818 Posts
Discussion Starter #6
Is this right?

Tonight my buddy was checking for problems that you guys had mentioned with the filters. He said he has a 12" line that goes from the bottle to his filter and found that on the end that goes to the filter it's tappered down to what he said is about the size of of #40 jet.
The kit is a NOS cheater kit, is the line suppose to be that way?tks
 

·
Administrator
Joined
·
136,626 Posts
I dont think it should be .040" If it is.. it means the most the system will be able to flow is a .040.. Is this the filter fitting? Is it a NOS brand NOS filter?
 

·
Registered
Joined
·
818 Posts
Discussion Starter #8
From what he said it was on the end of the line going into the filter and it is a NOS filter. I'm going to drop by and have a look tomorrow.
 

·
Registered
Joined
·
818 Posts
Discussion Starter #9
Well the line was definitely not a nitrous line and I'm sure it will work this weekend.Tks for advice guys it got him looking in the right area after messing with other things all summer.
 

·
Registered
Joined
·
818 Posts
Discussion Starter #11
Update

He got to try it out this weekend and went from 10.20's to 9.50's on a crappy air day so it's definitely working now.
 
1 - 11 of 11 Posts
Top