Yellow Bullet Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
me and a buddy have a lil fox hatchback that we turned into a lil street race car to keep us busy when the race car is down and we recently redid the nitrous wiring and now when the nitrous is activiated it will turn on and off during a test pass.... we already checked the grounds and swapped relays and it still does it... its a NX single efi fogger(wet kit) on a 5.0L were using a WOT switch.... any tips on what else we should check?
 

·
Registered
Joined
·
624 Posts
I've seen were the window switch was not compressing enough and the drivers foot would tend to lift enough when the nitrous was active.
 

·
Registered
Joined
·
5,240 Posts
it doesnt have a window switch... just a WOT switch...

it has a 30 amp relay, would that maybe be the cause?and we would need a 40 amp?
Well, I gotta say, the WOT micro switch may of cost me the win at Drag Week in '06.. Went into the second round on a by and had the car surging a few times, went into the semi's with the same problem after looking things over. I went over things again before the finals and didn't find a thing.. I figured what it was a few weeks later, turns out the micro switch was "fluttering" off and on, made an adjustment, all was fixed. Who'd a thunk that such a simple thing was the problem, never thought to look at it before. You can BET I check it pretty regular, now.
 

·
TRZ Rocks!
Joined
·
3,737 Posts
Well, I gotta say, the WOT micro switch may of cost me the win at Drag Week in '06.. Went into the second round on a by and had the car surging a few times, went into the semi's with the same problem after looking things over. I went over things again before the finals and didn't find a thing.. I figured what it was a few weeks later, turns out the micro switch was "fluttering" off and on, made an adjustment, all was fixed. Who'd a thunk that such a simple thing was the problem, never thought to look at it before. You can BET I check it pretty regular, now.
been there done that,

make sure that thing is absolutely mashed when on. If you're barely hitting it, Chassis flex/cable flex,drivers foot moving slightly will cause all sorts of weird things
 

·
Registered
Joined
·
1,860 Posts
Put a new micro switch on it. Only use it for 85 or 86 on the relay, don't ground the solenoids through it.
 

·
Registered
Joined
·
39 Posts
Well, I gotta say, the WOT micro switch may of cost me the win at Drag Week in '06.. Went into the second round on a by and had the car surging a few times, went into the semi's with the same problem after looking things over. I went over things again before the finals and didn't find a thing.. I figured what it was a few weeks later, turns out the micro switch was "fluttering" off and on, made an adjustment, all was fixed. Who'd a thunk that such a simple thing was the problem, never thought to look at it before. You can BET I check it pretty regular, now.

x2 We had that same problem like a bunch of times in my dads car. What was happening was the linkage under the carburetor was loose so we would get a different result every time. Some times it would touch the switch and then the pass after it would be a quarter of an inch off the switch. I would check the switch and your cable and linkages and everything.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top