Yellow Bullet Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
27,956 Posts
Discussion Starter · #1 ·
Now that I have some of my issues worked out of my car to where it will get down the track, I have a converter question...probably Hutch can answer this one. How do I tell if my converter is letting too much power get by it on the top end? The reason I ask is no matter which jet I put in my plate system it really doesn't seem to pick up much at all on the nitrous.

Most of the cars in the field are seeing at least a second difference in the eighth mile, I see about 7/10 and that stays the same if I run a .82 jet, a .91 jet, a 102 jet, a 110 jet or a 116 jet.

Mph doesn't change much either, in fact that is why I'm wondering if I have a converter problem...the car just doesn't MPH on the nitrous at all. Fastest it has ever gone is 120, usually runs 118 and some change.

It will run 5.90 at 118 on a .082 jet, and 5.80 @ 118 on a 110 jet.
It has a 4.10 gear with a 275/60 DR weighs 3348 and goes through the lights at 7074 rpm. In the eighth mile. I shift at 7400 and it drops about 1100 rpm on the 1-2. On motor it will run 6.55 at 106.

From the auto math calculations that is about a 16.50 % slippage rate from what I can come up with. It may be wrong I don't know. You think it is letting some power get by on the top?
 

·
Registered
Joined
·
15,547 Posts
Now that I have some of my issues worked out of my car to where it will get down the track, I have a converter question...probably Hutch can answer this one. How do I tell if my converter is letting too much power get by it on the top end? The reason I ask is no matter which jet I put in my plate system it really doesn't seem to pick up much at all on the nitrous.

Most of the cars in the field are seeing at least a second difference in the eighth mile, I see about 7/10 and that stays the same if I run a .82 jet, a .91 jet, a 102 jet, a 110 jet or a 116 jet.

Mph doesn't change much either, in fact that is why I'm wondering if I have a converter problem...the car just doesn't MPH on the nitrous at all. Fastest it has ever gone is 120, usually runs 118 and some change.

It will run 5.90 at 118 on a .082 jet, and 5.80 @ 118 on a 110 jet.
It has a 4.10 gear with a 275/60 DR weighs 3348 and goes through the lights at 7074 rpm. In the eighth mile. I shift at 7400 and it drops about 1100 rpm on the 1-2. On motor it will run 6.55 at 106.

From the auto math calculations that is about a 16.50 % slippage rate from what I can come up with. It may be wrong I don't know. You think it is letting some power get by on the top?
I'd answer this, but........ You dont like me:(
Dawg
 

·
Super Moderator
Joined
·
19,971 Posts
When you step up the nitrous does the car use more nitrous? Im just wondering if you have exceeded the flow rate of the solenoids you are using.
The slip sounds high at the 1/8 but is can't be compared to a 1/4 mile pass number either. The shift drop sounds pretty good also.

Let me know, Hutch
 

·
Registered
Joined
·
27,956 Posts
Discussion Starter · #4 ·
Yes

When you step up the nitrous does the car use more nitrous? Im just wondering if you have exceeded the flow rate of the solenoids you are using.
The slip sounds high at the 1/8 but is can't be compared to a 1/4 mile pass number either. The shift drop sounds pretty good also.

Let me know, Hutch

Yes, it uses more nitrous. Steve flowed my system, it should take up to a 120 jet.
 

·
Super Moderator
Joined
·
19,971 Posts
If you are sure that the tuneup is not too rich and as you step up the system you are not losing ET due to starting line traction then I would say its time to load the motor a little harder and you would need a tighter converter to do that.

Hutch
 

·
Registered
Joined
·
27,956 Posts
Discussion Starter · #6 ·
Yep

That's what I was afraid of...I said a couple weeks back in another post it was like my converter was working backwards. Not absorbing anything on the initial hit and letting power get by on the top. As far as the fuel pressure goes I have it set at 6.5 lbs flowing through a 73 jet. The plugs look good, it may be just a touch rich...but I mean just a touch.

It sucks because I wasn't smart enough to modify the firewall for the Deadenbear case before I put the motor and transmission in and now it's real whore to get the bolts out of the transmission. Guess that's what I get for getting in a hurry to get the car back going again.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top