Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
973 Posts
Discussion Starter · #1 ·
I have a 355sbc with a s480 turbo!

I just installed a jgs 60mm gate and it won't make any boost at all!

I have a 2.5 inch diameter pipe running to the bottom of the gate off the header merge.

I have the reference line off the turbo compressor to the bottom of the gate. I have the top vented to the atmosphere with the heaviest spring it made 0 pounds of boost!

WTF!

Is this gate too big?

Did I hook it up wrong I assume it is like all other gates and the reference from the turbo goes to the bottom.....it had no instructions with it!



Please Help YB!
 

·
Registered
Joined
·
973 Posts
Discussion Starter · #2 ·
There was an extra piece that machined piece that pushes on the valve! Should I have no put that in?
 

·
Registered
Joined
·
49,830 Posts
There was an extra piece that machined piece that pushes on the valve! Should I have no put that in?
Yes it will need the valve seat.
 

·
Registered
Joined
·
973 Posts
Discussion Starter · #5 ·
I just went out there I think that the compressor housing was not on properly I will test tomorrow! To late tonight!
 

·
Registered
Joined
·
18 Posts
Don't even bother starting and testing the car until you put the valve seat in - without it it is like the gate is open - you will not build boost. Put the spring in you want for base psi and put the seat in and you will be fine.
 

·
Custom Engine Shop
Joined
·
3,812 Posts
There was an extra piece that machined piece that pushes on the valve! Should I have no put that in?
As stated that is the valve seat. No seat no boost....
IT has a v-band. Pop the v-band off and install the seat.
 

·
Registered
Joined
·
973 Posts
Discussion Starter · #9 ·
I always had the valve seat in the gate! Like I stated last night I went back out and I had taken the compressor housing off to drill and tap a boost reference and I guess I didn't have the compressor housing on properly! I drove it this morning and it makes boost just fine. The problem is I have the biggest spring in so I'll have to go back and put the light spring in to see how low the boost goes!



Thanks for the help YB!
 

·
Custom Engine Shop
Joined
·
3,812 Posts
I always had the valve seat in the gate! Like I stated last night I went back out and I had taken the compressor housing off to drill and tap a boost reference and I guess I didn't have the compressor housing on properly! I drove it this morning and it makes boost just fine. The problem is I have the biggest spring in so I'll have to go back and put the light spring in to see how low the boost goes!



Thanks for the help YB!
Right-on. Get the spring swapped!
 

·
Registered
Joined
·
973 Posts
Discussion Starter · #11 ·
Right-on. Get the spring swapped!
I was amazed at the quality of the wastegate when I first took the small spring out! These wastegates are no laughing matter! They are super nice! I'm glad I spent the money and got a JGS!
 
1 - 13 of 13 Posts
Top