Yellow Bullet Forums banner

1 - 20 of 93 Posts

·
Registered
Joined
·
471 Posts
Discussion Starter · #1 ·
I consider myself a reasonable person and since I am just a tad younger than George Klass, tried to role with the punches of life but sometimes it's difficult to be reasonable. I have a 7530 MSD Ignition Controller in my race car. It's an older unit but it has always been in the interior and never exposed to the weather and very little time on the unit. I put a fresh engine in recently and when I tried to start the car is would not fire. No spark, checked all the connections etc. I borrowed an older 7-AL from a friend and it fired on the first revolution. I called MSD and was told to send it back for repairs which I did. They sent it back to me and said they could not find anything wrong. I went to a test & tune the next week-end and and made a couple of passes and the car ran great. At the track I replaced the 7-AL with the 7530 and again it would not fire. Changed back to the 7-AL and it ran fine with a couple of 9.75 passes. I called MSD and I was asked to do a couple of checks (cranking voltage on the small red wire & oms check). Batter voltage was 12.4 and cranking voltage on the red wire was 10.5. As instructed I checked oms resistance between the head and block. Less than 30 oms. MSD said all the checks were within specs and to send it back and this time they would replace the unit because it is their policy to replace the unit on the second return. I get the unit back today and they sent my old unit back and said they could not find anything wrong. I called the guy (Edgar on ext. 2234) and asked why it was not replaced like he promised and he said they do not make a 7530 and longer so they will not replace it. He said the 7530 was replaced with a 7530T. I said send me a 7530T and he said they would not. I argued because they did not tell me that before I sent it back. Edgar said he forgot to tell me about not replacing the 7530. He said it slipped his mind. Then he asked if I couldn't have someone else wire it in this time. Thats when I lost my cool. I told Edgar I am an certified aircraft electrician and I have enough phucking confidence in my ability to wire it correcty. I have over $100 in shipping and they basically said tough shit. The conversation ended with a couple of motherphuckers from me. I try not to let things get to me but damn. I have not used anything execpt MSD units. Are there any other brands out there that would be worth buying? I will not support a company that will not stand behind there product and lie to it's customers.
 

·
Read Only
Joined
·
0 Posts
Call 915-855-7123 and talk to Lou at 2262. He is the only one that I have dealt with that knew what was going on.
 

·
Registered
Joined
·
7,434 Posts
If I had a dollar for every time I've heard very similar complaints about MSD, I could start a competing company. :rolleyes: When I put a 7530T box in my car, I called them for help a couple of different times. They were totally useless and acted like I was an idiot. I never called again and we sorted everything out on our own. I like the features MSD offers but I would buy something different next time if anyone made a ignition box that offers the same features....
 

·
Registered
Joined
·
2,137 Posts
My digital 6+ has been "rebuilt" 3 times. This last time they agreed to send a new one and they sent me the same damn box back...says they replaced an unstable regulator this time...WOW...

This box has 0 "miles" on it still and it's costing $500+ so far...nice.
 

·
Registered
Joined
·
565 Posts
Sorry to hear about your issues.

Highperformancecontrols.com is currently buliding a Digital CD controller with Data Acquision and will have all and MORE of the MSD 7531 features. In addition it will have a wide band O2 for data, and upgradable to activate drive shaft based Traction Control.

Stay Tuned, will let you know when it is ready to go..

Regards,

Rob Zarcone
HPC Canada..
 

·
Registered
Joined
·
136 Posts
August 30 at Cecil County new MSD 7531 broke in staging lanes during first round of gualifying, borrowed a 7530T that was used and told worked, would not work, borrowed another 7531 to get the car running, started up first try. Sent original 7531 back and bought another new $900 7531 plugged it in and worked fine. Crazy to think that I will have over $2,000 in an ignition. I will be taking two to every race. Last year on another car same story, had another 7531 new out of the box would not work.
 

·
Registered
Joined
·
6,413 Posts
I am sorry to read this, they have always been great to work with for me, I deal with Joe Pondo, he has been there for a long time, I am not saying you will get anything resolved, but just who I deal with, BG
 

·
Registered
Joined
·
731 Posts
good luck finding something even close to as good
 

·
Not a Hemi!
Joined
·
1,517 Posts
This post is not making me feel any better. I just sent in my 7531 on yesterday. Car quit after about 1/2 hour total run time on the box.
 

·
HeadCaseRacing
Joined
·
11,611 Posts
My first 7531 went bad. Turned the car on one day and it smoked. Sent it back and they said it a old rev. And couldnt fix it. So I asked could you do anything for me on a new one. Sorry I cant do that. So now I have a new one and have not had one problem. This is what happens when a company get BIG and sell alot of product. About 99% of the cars build have MSD.
 

·
Registered
Joined
·
513 Posts
wow, I just sent mine back last week! I got a call from a guy who stated to call him back about my 7531. When I called nobody knew what I was talking about even the guy who called me. He acted as if I was lying so I explained how would I have your ext/name if someone did not call me.

Mine has gone in for hitting the rev limits to quick. when going down the track it will not rev past 5200 even though I have the limits well past 10,000 rpm. It also pops/sputters when I hit that 5200 rpm range. I am going to try changing the trigger wire to a shielded one that MSD sells part#8862.

Still waiting for a call from MSD on my brand new box.
 

·
Registered
Joined
·
565 Posts
wow, I just sent mine back last week! I got a call from a guy who stated to call him back about my 7531. When I called nobody knew what I was talking about even the guy who called me. He acted as if I was lying so I explained how would I have your ext/name if someone did not call me.

Mine has gone in for hitting the rev limits to quick. when going down the track it will not rev past 5200 even though I have the limits well past 10,000 rpm. It also pops/sputters when I hit that 5200 rpm range. I am going to try changing the trigger wire to a shielded one that MSD sells part#8862.

Still waiting for a call from MSD on my brand new box.
Hey man,
Go into your Data Editor, and scroll down to the bottom.
Then open your Brown out and Watch Dog..
Reset them both to zero and see if your misfire goes away.
I've seen the 7531 do some funny misfire stuff when the brown out is above 6?

Give it a shot
 

·
Registered
Joined
·
5,691 Posts
yesh msd sucks donkey ball.

sent a box to them three time after that is just sold it. the guy i sold it to ended up having to send it back too!

i have had many problems with msd customer service and msd quality.

after too many problems i removed every part that was from msd and refuse to ever use their product again!
 

·
TwistedTerror
Joined
·
4,013 Posts
Their products work good for us, but guess their employee's suck. Our MSD coil burned up last year, but don't know who's fault that was lol.
 

·
Registered
Joined
·
1,455 Posts
Bob I am sorry to hear they arent going to help you, I can testify to the thing working properly to begin with and then it just quit. Its not like you wired it wrong or anything, it was fine, then one day not fine. So when it came back its not like you were a novice to it, you knew what you were doing. That blows, they should atleast give a credit towards the new one. Well you are welcome to use the 7AL2 til you get the new, whatever it may be. Damn shame when you have an entire thread full of people with similar problems with the company. I gotta say Bob you are the most loyal to people who treat ya well and who are supporters of our race series, but when you piss Bob off.....Get out of his way!!

Rich
 

·
Registered
Joined
·
1,823 Posts
We sent a 6a in a few months ago to get fixed for a customer and i was told its only about 50.00 to fix with the shipping included they called two weeks later and said that the repairs were going to cost me as much as a new box i told the customer and he just said screw that and went another route and has been happy ever since
 

·
Registered
Joined
·
2,290 Posts
MSD SUX. I will steer every person I can away from them.Their tech persons suck, shipping back and forth, more stupid tech people...
2 MSD DIS4 boxes. My friend went thru 3 of the same. After going to the Crane HI 6 boxes Ive never had any issues again.
 
1 - 20 of 93 Posts
Top