Yellow Bullet Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,772 Posts
Discussion Starter #1
A friend of mine is trying to add a 7760 3 stage module to control 2 nitrous relays but it's not showing up in MSD View. Its connected to a can bus and the can buss has the terminator connected. Is there something that needs to be downloaded first or does view recognizes a module as soon as you plug it into the can bus?
 

·
Registered
Joined
·
3,772 Posts
Discussion Starter #3
Yes, followed instructions that came with the 7760 module but when opening the MSD view program it doesn't see the module. Can the terminator that came with the grid be bad?
 

·
Registered
Joined
·
2,422 Posts
With power off all you'll see is the 7730, with power on, you should be seeing both in MSDView listing. I suppose anything could be bad, can bus hub, terminator, 7760 itself. Got any buddies you can swap parts around with trial and error test?
 

·
Registered
Joined
·
38 Posts
mine does the same thing bought it on ebay said it was a display unit. it only weighed 10.5 ounces. without the wiring harness msd said that waas not the right weight. say they sent some out with nothing inside for display. shipping took way to long out my money now as ebay wont allow anything after the 30 days stuck with a nice looking hunk of junk
 

·
Registered
Joined
·
3,772 Posts
Discussion Starter #6
Beyond, I'll have to try plugging into another grid. Thanks.

Mad427, this one came from a retail company.
 

·
Registered
Joined
·
3,772 Posts
Discussion Starter #8
I know MSD sometimes get the pinouts screwed up on their cables, that's another possiblity.
Going to order a new can bus and see if that's it, thanks.
 
1 - 8 of 8 Posts
Top