Yellow Bullet Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
489 Posts
Discussion Starter #1
we racd over the weekend and no matter what changes i made the car missed. i hade this problem a few years ago and it turned out to be the battery (regular sears batery) but the battery now is a two old turbo start.
also on the racepak computer it shows rpm spikes only on nos it does this
can it be the battery or maybe the msd retard box???it has a crank trigger too.

thanks
 

·
Super Moderator
Joined
·
9,240 Posts
Could be the crank trigger, a solenoid problem, several things. Check all of the nirtrous plumbing and solenoids and all of the lectrical connections (especially grounds). Check the cap/rotor too (check for wear and rotor phasing).
 

·
Registered
Joined
·
2,054 Posts
We have ran into SOooo many things that can cause a mis. I'll share a couple of weird ones.
1. throttle micro switch was going on and off, why because it was right on the edge of clicking off. The linkage was solid to the body, the engine twisted and the throttle actually let off slightly enough so the switch was going on and off.
2. Bad transbrake button, we chased this one for 7 months straight. It had an adjustable button for sensativity, the spring wore out so the button was going on and off. We replaced it and the misses went bye bye and we through a HUGE party to celebrate!!!
 

·
Administrator
Joined
·
136,621 Posts
I was using two 12volt yellow caps and switched to one 16 volt AGM battery. Get the battery load tested at a local autoparts store or battery dealer. Do you have an alternator on this car?
 

·
Registered
Joined
·
489 Posts
Discussion Starter #7
no alternator.
the computer says it is 15.2 volts on the run.
it does not make any sense.on hp it is fine and spraying it misses
and rpm spike show up on the computer,can it be the msd retard controller,since the crank trigger wire goes into that??
 
1 - 7 of 7 Posts
Top