Yellow Bullet Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
480 Posts
Discussion Starter · #1 ·
Hi guys , been looking in for a while & decided to join , great info here & has helped me no end.

Run a 440 RB 68 charger , around 4300lb , PB is an 11.03 1/4 mile @ 125 mph , NX 6 stage gemini plate running 300 shot with 8 1/2 lb fuel pressure , dedicated fuel cell with holley blue leccy pump dead headed to solinoid , pulled 10* timing , bottle pressure 1000 psi.

Took a run today & the only change i made was to drop the fuel pressure down to 8 1/2 lbs from 9 lbs , got mid track & she started to misfire around 5500 rpm , came off the throttle & noticed a burning smell under the bonnet , turns out the 850 mighty demon primary boosters are melted , along with the 4 hole spacer , throttle blades are ok but have a blue tinge to them & molten metal all over the engine bay.

Any ideas why this could of happened? running NGK 8s , plugs looked real good , best i've ever seen em , timing mark was @ the bend on the ground strap , also a thin black line @ the base of porcelain.

Thanks in advance , you can probably tell i come from London England.
 

·
Super Moderator
Joined
·
12,234 Posts
Sounds to me like it may have had debris stuck in the nitrous solenoid at the end of the run maybe ??? Is you bottle empty ?? If not, crack it open and see if you hear it leaking past the solenoid ?? SJ
 

·
Registered
Joined
·
480 Posts
Discussion Starter · #4 ·
Thanks for the replies.

Changed bottles on that run so bottle was full also solinoid was ok , the motor was misfireing on every run above 5500 rpm , i know a few guys were having issues with the heat & misfireing , weather was around 90* centigrade & no air.

Motor runs fine NA , just a problem with the nitrous runs , when i get the misfire i flick the gear vendors (over drive) , as soon as the rpm drops back to around 5000 rpm she picks up again , so i know the problem is RPM related.

Leaning towards the rotor/cap phasing , i'm using the MSD distributer with the 3" rotor cap , thinking of going with the larger 5" adapt a cap from MSD.

Any other problems it could be?

Thanks in advance.
 

·
Registered
Joined
·
481 Posts
I had a problem like that years ago...

I got greedy and tried a NOS double cross plate...

It went lean, nipped a plug, backfired thru the carb really bad, torched a piston, bent 4 butterflies and melted 4 boosters.

Oh yeah... it melted the cross bars in the plate... so that was junk too. :eek:
 

·
Registered
Joined
·
480 Posts
Discussion Starter · #7 ·
Still have'nt got to the bottom of it (motor appart) , would be good to know the cause as i can't be doin with painting the bulkhead again , maybe i lifted off the throttle before shutting the nitrous off , i know i know , gotta fit a throttle switch.:rolleyes:
 
1 - 7 of 7 Posts
Top