Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
573 Posts
Discussion Starter #1
Have a local car lot that I do work for and they bought this 94 ZX9R. It ran fine when they got it, but it has sat for a few months and now it won't start. They have had several motorcycle techs say they will work on it, but never show up to get it. I don't know the first thing about motorcycles, but I told them I would try to fix it!

Sometimes it will not crank, when it won't crank, you can hear something clicking in the fuseblock under the seat. If you beat on it with the palm of your hand, it will crank. When it does crank, it still will not start. I'm gonna go out later today to see if it has spark. I have a wiring diagram for the bike, but I haven't really looked at anything yet. Just curious about this fuseblock, if it maybe has a starter relay incorporated in it??

Thanks

Darin
 

·
Registered
Joined
·
3,428 Posts
not sure about a ninja but on my quad the batt and starter solenoid are both under the seat
check for corrosion, loose connections and charge
 

·
Registered
Joined
·
573 Posts
Discussion Starter #6
They have had it on a charger for a long time, and have left it on trying to start it. I'll look and see how old the battery is... I've been doing a little reading on the thing, and alot of motorcycle sites say that a bad battery can cause symptoms like this. When it gets a little warmer, I'm gonna go to the shop and look at it, still waiting on gas company to run a line and set a meter so I can get the heater goin! I'll report back with what I find.

Thanks
 

·
Registered
Joined
·
498 Posts
More than likely the battery is gone or loose bad connection. your hearing the starter solinoid clicking. where is the bike located? might be able to help.
 

·
Registered
Joined
·
573 Posts
Discussion Starter #8
just got back from messing with it a little. Has a new battery, I charged it up and it cranks good, but sometimes it still just clicks. If I hit the fusebox while hitting the starter button, then it will crank. It has good spark on all 4 wires, and I put new plugs in it while I was there. Gonna make sure the fuel pump is working next...

Is the solinoid replaceable or do you have to replace the whole box?
 

·
Tellin' it like it is
Joined
·
9,799 Posts
Is it one of the green/white/blue ones? I remember when that bike was new it was hot shit.
 

·
Registered
Joined
·
7,207 Posts
Check the wiring from the clutch handle and kickstand to make sure the solenoid is getting all the (-) negative signals it is supposed to. If any of those are off the bike won't turn over or start, just click.
 

·
Tire Waster
Joined
·
7,086 Posts
A good battery is critical on a bike! I had weird symptoms with my Suzuki: low idle, hard to start when cold, soggy response down low. Finally one day it refused to crank. It was the battery all along! They only last around 2 years and that's how old mine is.
 

·
Registered
Joined
·
573 Posts
Discussion Starter #12
OK, went back to check more, and it needs a fuel pump. The pump would not work, and it was getting good power and ground. It must be trying to spin, but is drawing alot of amps. When i unplugged it to check for power, the engine would crank every time I tried it. when I plugged it back in, it went back to not cranking. I took it off and ran wires to it from a regular car battery and it worked, but it was extremely noisy.

Could the pump be drawing so much that it will sometimes not crank?? This is all new to me, I've never even sat on a motorcycle, let alone worked on one!!

Thanks again

Darin
 

·
Registered
Joined
·
81 Posts
Mine will do that when they sat for a long time. Change spark plugs and that will do it you also have a starter going bad.
 
1 - 13 of 13 Posts
Top