Yellow Bullet Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter #1
Ok, I'm not too sure exactly what the issue is here, but the car is an 86 ford mustang. AJE k member, sbc (I know, long story) but anyways, I have the correct mounts and such from aje, and the whole drive train is in the car now, motor, trans, driveshaft, rear end. but when I look at the car from the front the passanger side of the motor sits 2 degrees higher than the driver side. Anyone run and aje k member or a similar setup and run into a problem like this? I would assume left to right the motor should be completely level. Any suggestions would be appreciated. Thanks in advance guys
 

·
Super Moderator
Joined
·
9,240 Posts
Sounds screwed up. Make sure the car is square and level. Then check the engine to see if it is really tilted to the side. Maybe it is not sitting in the k-member correctly? If it is you might have to shim it to get it square??
 

·
Registered
Joined
·
407 Posts
Discussion Starter #3
Yeah, unfortunately that might be the case. (Shim) but that would be awful. Yeah, I checked to make sure the car was level. Perfect 0 across the radiator support. Then 2 degrees high on the passenger side. When I put the level on the intake. Always something....
 

·
Registered
Joined
·
14,969 Posts
Had same setup, but made motorplate/midplate. Headers were fun.
 

·
Registered
Joined
·
407 Posts
Discussion Starter #6
yeah, can't wait. I almost went the motorplate route, but after hearing how "easy" the K member route was I did this instead lol
 

·
Registered
Joined
·
916 Posts
me too then cut em off and went with plates! and early vette headers(slightly modified)btw you dont have a shim behind the motor mount do you?
 

·
Registered
Joined
·
950 Posts
Not to be a jack ass or anything but did you check and make sure the motor mounts don't have any kind of offset ? upside down ? left on right side ?? etc.etc

You never know man :p.

Neil
 

·
Registered
Joined
·
407 Posts
Discussion Starter #9
Well, I had two friends come over just to get a second view on this. The mounts are slotted, but even with all the adjusting you can do it wouldn't get level. (I think the k member might be bent somewhere?) So I shimmed the side that I need higher just to get the thing to sit level. However I dont like the thought of running the car like that. So now that I have it sitting exactly where I want it we're going to mock up a motor/midplate and get rid of the mounts on the k member. (probly should have done that from the beginning) but you live and learn. Thanks for the help and suggestions guys. oh, and off topic here, possessed1, are you a member on chitown racing too? Something about that mustang looks familiar
 

·
Registered
Joined
·
950 Posts
Well, I had two friends come over just to get a second view on this. The mounts are slotted, but even with all the adjusting you can do it wouldn't get level. (I think the k member might be bent somewhere?) So I shimmed the side that I need higher just to get the thing to sit level. However I dont like the thought of running the car like that. So now that I have it sitting exactly where I want it we're going to mock up a motor/midplate and get rid of the mounts on the k member. (probly should have done that from the beginning) but you live and learn. Thanks for the help and suggestions guys. oh, and off topic here, possessed1, are you a member on chitown racing too? Something about that mustang looks familiar
Yeah i am a member but i do not post much over there , to much shit talking for me :p lol
I do race some of the true street events and tested at a few RSD's in the past . Its hard to miss that orange car lol . :rolleyes:
 

·
Registered
Joined
·
525 Posts
We put an AJE in a 63 Dart and it wouldnt even bolt to the frame had to cut it apart and fix it.Had a another brand for my Firebird with a sbc had to cut and lower both motor mounts. They all have problems you just have to fix em.
 
1 - 11 of 11 Posts
Top