Yellow Bullet Forums banner

101 - 110 of 110 Posts

·
Registered
Joined
·
1,957 Posts
Discussion Starter #103
Finally got the car out. Not so great results...

The S480 Easily made boost, so much so that I had to keep pulling boost by speed to get it to hook. Fought traction all night but slowly ramping in boost over 4 seconds or so I was able to run some 9.70's @ 150. @ 24 stink'n lbs and 13*. Dog slow for the amount of boost in the thing. Saw a few small coolant drops on my hood after about 6 passes. Couldn't figure out where they came from. Last run of the night I blew a HG (I think). Puffing smoke like crazy stunk like coolant. Logs looked great. 12-13* in it, 10.8 AFR and plugs look fine. No idea why it pushed coolant. I will say I used the MLS felpro HG's this time around instead of the usual LS9 gaskets. Also went with ARP bolts instead of studs. If we've proven the factory head bolts can hold 1200whp or so I think we can rule out the ARP bolts.
 

·
Registered
Joined
·
1,957 Posts
Discussion Starter #106
Had the injectors flowed. All within 2% of each other so that wasn’t the problem.

Checked the torqe on the head bolts before pulling and they all seemed to still be at 78 ft lb. Yanked the Pas side head off. #4 was blown huge. Head and deck seemed straight. No idea what/why this let loose. Plugs were oldish so I couldn’t get a great read, but there were no signs of detonation and the heat marks I could see on the strap looked conservative about half way down the strap. 10.8 AFR peaked around 5800 25lbs 13* of timing. This is with E85 7gph of water/meth (washer fluid) and 100* IAT’s.

Cylinder looked like it had a little galling. 90% sure none of the cylinders had any markings when I put the engine together. Rings gapped at 22/24 same as I’ve done on all my LS stuff. Figure I might have knocked the ring land out of that piston. Not sure what else would cause it, unless the ring was just cocked goofy.

Can’t pull the pan on this setup without removing the engine and I wasn’t ready to pull the motor yet. So I copper sprayed a used LS9 gasket and put the head back on. Torqued to 80ftlb. Cranking compression is the same as it was prior, so I threw everything back together. Started right up and seems ok. Cruised around quite a bit. The tune was reading really rich all of a sudden. Dropped a bunch of fuel out and it seems fine. Ordered a new WB02 sensor to be sure. I’ve had the same Bosch 4.2 sensor for 6-7 years now. I think it’s fine, but I want to be sure.





Sensitive content, not recommended for those under 18 Show Content
 

·
Registered
Joined
·
1,957 Posts
Discussion Starter #107
Think I found the issue. (or rather a bud on ls1tech pointed it out to me). I used the LS1 style gasket. It has a recess/notch for the 862 style heads. It blew right at that recess. I was thinking the smaller 3.9” bore gasket would be better on the 4.8. My mistake! Guessing that notched area is going to deform like crazy on a flat surface. Makes sense it leaked there. Wish I had known that before putting the motor back together completely. I’ll need to change the driver side head gasket to an LS9 as well.

 

·
Registered
Joined
·
1,957 Posts
Discussion Starter #108
4.8 is still alive... put up a new personal best last night of 8.80 @ 158.



Made it to the track again these last 2 weekends. I found some New "old stock" racing beat FB RX-7 adjustable road racing shocks on the Mazda forums. They don't even make them anymore that I'm aware of. Installed these with some 175lb springs up front on full firm. New tie rod ends and bushings all around. The nose of the car is like a rock now. Removed the limit straps and played with the launch and rear shock settings a bit.

Finally go the new 275 pro bracket radial tire to hook. Little room to grow on the 60' as well. Basically 4 more lbs of boost and almost running the same times as the 370" motor on 20lbs.

23-24lbs on 13* of timing. Pulling lots of power from the launch as well.

Made a few 9 sec passes going easy on it at first and trying to dial in the suspension. This was a WG pass around 12 lbs.

 
101 - 110 of 110 Posts
Top