Yellow Bullet Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,187 Posts
Discussion Starter #1
got the car fired yesterday.turbo barely wants to spin at idle.causes?80mm borg 1.32 exhaust on 388 sbc.when gets rpms up and lil more heat in it spins freely.just curious.any fedback be appreciated.only had the unit for 4 months got new from you.maybe ive done something wrong pm if ya see this.thanks greg ruppe
 

·
Registered
Joined
·
4,121 Posts
Does it spin freely by hand?? Feel any drag anywhere?
 

·
Registered
Joined
·
2,339 Posts
check to see how tight you have the compressor housing on. I noticed that if I tried to crank the housings down that it seemed to bind a little. Once I backed them off, they spun freely by hand.
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #6
ok..back at the shop today...loosened the compresor housng and reapplied pressure against it and tightened up.cranked nad fspun freely at idle and cut off.moved it by barely spinning the wheel.after a lil heat got in it it moves easily.i put 1.32 on it cause i plan on going to larger motor later aroun 400+ on sbc.but im only looking to get 5.40s in the 8th for the local radial class.i went 6.14 with 2 lil ole 63s last year.if it dont work the way i want ill just run the 5.99 class no rules except weight
 

·
Registered
Joined
·
3,336 Posts
got the car fired yesterday.turbo barely wants to spin at idle.causes?80mm borg 1.32 exhaust on 388 sbc.when gets rpms up and lil more heat in it spins freely.just curious.any fedback be appreciated.only had the unit for 4 months got new from you.maybe ive done something wrong pm if ya see this.thanks greg ruppe
Give us a shout Monday if you have any issues whatsoever. The units are assembled with cam lube, so/and if they sit a long time without use sometimes the cam lube will get a little sticky but once hot oil passes through and works out of the turbo it should free spin quite well. We use cam lube in case some customers forget or get the oiling wrong feeding the turbo when first starting up a new combo.....the cam lube gives you a few mins of protection.
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #8
Give us a shout Monday if you have any issues whatsoever. The units are assembled with cam lube, so/and if they sit a long time without use sometimes the cam lube will get a little sticky but once hot oil passes through and works out of the turbo it should free spin quite well. We use cam lube in case some customers forget or get the oiling wrong feeding the turbo when first starting up a new combo.....the cam lube gives you a few mins of protection.
it moves good now.sounded awesome on the transbrake and building boost around 3200rpm.belive it was what ya said.cause ive got it to engine temp to 172 and let cool the refire and she moves a smooth as it can get.sorry for incoveince.thanks greg ruppe
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #10
Where you been Greg? You have not shown your face at any of the Drag radial races.
been working and fishing.had some issues come up with neighbor messing with some stuff so i have been home babysitting the house and making sure his damn horses dont tear anything else up.and of all things its my wife brother hes a spiteful bastard im done i just gotta get a boot from the bonnet to the pipe from turbo.may need ya help on the tune.have to hook up with ya on this.she sounds good and strong and i know that 5.37 ya ran is gonna be tough.lol.im wanting to race but scheduling is hard.floyd wanted me to bring it today.but its mothers day what would i be if i didnt stay and celebrate with my mom and give her a cookout.
.but as long as it works.pm me with ya # and i see if i cant bring this thing to ya.i alos had to take trans back out to change lever for the tci shifter cooks lever wouldnt work with my new shifter.heres a pic of the engine bay but aint the cleanest.got new radiator on order also.had to throw in something that was close to size and would fit.
 

·
Registered
Joined
·
3,336 Posts
it moves good now.sounded awesome on the transbrake and building boost around 3200rpm.belive it was what ya said.cause ive got it to engine temp to 172 and let cool the refire and she moves a smooth as it can get.sorry for incoveince.thanks greg ruppe
Anytime man....just give us a shout if you need anything else.
 

·
Registered
Joined
·
1,588 Posts
The units are assembled with cam lube, so/and if they sit a long time without use sometimes the cam lube will get a little sticky but once hot oil passes through and works out of the turbo it should free spin quite well. We use cam lube in case some customers forget or get the oiling wrong feeding the turbo when first starting up a new combo.....the cam lube gives you a few mins of protection.
That is an excellent idea.
 

·
Registered
Joined
·
1,187 Posts
Discussion Starter #15
Looks like you made good progress Greg. Who built your carb?
i got it from justin burgess.had it on his blow thru combo with the procharge setup he was running.he said i belive was underpressure performance in s.c did it.all i need now is the hump hose to the bonnet and a good tune on it.think ya can help me and take a look at what i got going on?i had a demon blow thru when i first started all this blow thru stuff.let me not say what i think bout that carb! starts with a j and ends with k.lol floyds running it on his but keeps getting fouled plugs on his setup.maybe after 3 runs they are gone.hes gon 5.52 so far with his but thats backhalf with old tires.i belive i got alot of power if i get the tune down.like i say im new to this and ya the man right now around here with the knowledge.thanks greg ruppe
 

·
Registered
Joined
·
49,435 Posts
1 - 16 of 16 Posts
Top