Yellow Bullet Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
981 Posts
Discussion Starter · #1 ·
I need opinions on whether this motor is running properly or not. Its a 434sbc 4.155x4.000. heads are brodix-11x they flow [email protected] with a 2.125 valve, int volume is 243. Exh is [email protected] with a 1.600 valve. cam is .681int, .660exh, [email protected] is 282,288 , lobe sep 109. compression is about 13.5,super vic intake,pro systems 1000hp 4150. it has a glide with a 1.82, 9.5 inch converter it stalled at about 3800 footbraking. Car is a 78 malibu car weighs 3410 w/driver, 28" et street. It went [email protected] it was 97*, 63% hum, calt 3600. car has a 4:10 gear. that was the first and only pass right out the trailer.
60ft 1.68. total timing 35* hope I did not leave anything out. inputs please???????????????????
 

·
Registered
Joined
·
2,064 Posts
The et is soft for the mph. The 1.68 60' is about .2 slow for a 10.8x, so I'd guess you have traction issues. The cam/converter/gear/tranny would not be my choice for a 3400lb N/A car (assuming this is NA).

I would expect it to run harder, but given this was the 1st trip, I would run/tune it some more before I started changing things.
 

·
Registered
Joined
·
4,458 Posts
Yea that's a lot of cam and a little converter and bad final drive for such a heavy car but the MPH looks decent for the weather conditions so the motor is making decent power. Like said, I'd bet some tuning will pick it up some the way it is.
 

·
Banned
Joined
·
71,969 Posts
Probably will get close to it when he sprays it.
 

·
SOFA KING WHAT?
Joined
·
43,675 Posts

·
Banned
Joined
·
71,969 Posts
I was thinking trans brake .............. :confused:
 
1 - 12 of 12 Posts
Top