Yellow Bullet Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
395 Posts
Discussion Starter #1
hey a little help if anyone knows would be helpfull.
i am installing a comp engenering 4 link sub frame in a 71 camaro and it is going good but when I level the sub frame the rear of the rails where they contact the rear pannel seems very high up the pannel





the photos show the rail but it needs to end up where the battery cut out switch is. dose this seem right?
 

·
Registered
Joined
·
239 Posts
If you have the crossmember in at the correct height , and the 4 link brackets are also correct the frame rails kind of go where they go. I have never used a comp kit though , so I'm not sure how good of design it is.
 

·
Registered
Joined
·
545 Posts
Welcome to the world of one size fits most. This is why I try and fab my own rails from round tubing. Kits are great, when they work. Many times what you are seeing is what most others see also. Then you just put them where ever they happen to fit. The picture looks as if the high point of the rails is lower than the top of the stock wheel wells. This usually ends up with the lower mounts of the shocks hanging well below the housing and may comprimise the desired ride heigth of the car if you were planning a low stance. At this point you are at the mercy of whoever designed the rails and how well they did their R&D.
On a positive note, I do like the way the front brackets are fitted to the bend in the rails. Good luck.....Toni
 
1 - 4 of 4 Posts
Top