Yellow Bullet Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
I am going to be digging into this thing soon, and I will be needing to order parts also.
I am not sure what head gaskets, I am using yet.
Fel Pro 1003 rings a bell.
I have read alot of good stuff about Cometic.
My bore is 4.125"
Recommendations?

Dave
 

·
Registered
Joined
·
1,876 Posts
if you run mls gaskets just make sure your deck suface is smooth. some blocks have a rough finish and the mls gasket don't like to seal.
 

·
Registered
Joined
·
27,956 Posts
Fel Pro MLS Saturate the piss out of them with High Tack. I had issues with all MLS gaskets weeping between the layers, and never even bothered reusing a set. One of the local race engine builders here told me to try the High Tack trick and it worked flawlessly.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #7
Ok thanx for the tip.
I am not sure if I am going to use the Fel Pro regular 1004 or 1014 or a MLS

Dave
 

·
Registered
Joined
·
9,948 Posts
Fel Pro MLS Saturate the piss out of them with High Tack. I had issues with all MLS gaskets weeping between the layers, and never even bothered reusing a set. One of the local race engine builders here told me to try the High Tack trick and it worked flawlessly.

DON'T know WHY you had a problem,,, been using them since they came out and NEVER had one LEAK.........even on all
Aluminum motors.......
 

·
Registered
Joined
·
27,956 Posts
DON'T know WHY you had a problem,,, been using them since they came out and NEVER had one LEAK.........even on all
Aluminum motors.......

I don't either, got the tip from Bud Morgan at Morgan and Son racing engines. He had a couple do the same thing and he refuses to use them without the High Tack now. He has never had an issue either since though.
 

·
Registered
Joined
·
1,138 Posts
DON'T know WHY you had a problem,,, been using them since they came out and NEVER had one LEAK.........even on all
Aluminum motors.......
Hey I had a set of MLS gaskets leak water into the engine .Thought it was the block .So just for shits I tried Felpro blues an there it was ...not a leak
 
1 - 10 of 10 Posts
Top