Yellow Bullet Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
1,809 Posts
Discussion Starter · #1 ·
Long story short
Had car on the dyno
At some point during the Intercooler sprung a leak
Last pull it popped off a silicone coupler so I loaded in trailer and went home
Then I found the leak in Intercooler

Fast forward a week
New Intercooler
New intake gaskets (had a small oil leak from valley)
Pull all the plugs last night and number 8 hole starts pissing water out spark plug hole
So I crank it over and get the water out
(No other cylinders have water)
Spray em all down with wd40 To lube em up a bit
Turn on electric water pump and number 8 starts filling back up with water

I haven't done a leak down or coolant system pressure test yet but will today after work

Any ideas what broke what ?

Thanks
Devin
 

·
Registered
Joined
·
2,042 Posts
Last year I was running the 9333s with ARP headbolts. Lifted the head almost everytime out.... Ended up pressurizing the coolant system and blowing the rad hose off at the 660'.

Because of that , this year I switched to head studs, MLS gaskets and AN lines to and from the radiator.
 

·
Registered
Joined
·
279 Posts
Last year I was running the 9333s with ARP headbolts. Lifted the head almost everytime out.... Ended up pressurizing the coolant system and blowing the rad hose off at the 660'.

Because of that , this year I switched to head studs, MLS gaskets and AN lines to and from the radiator.
HG for sure, pull it off man.
 

·
Registered
Joined
·
1,809 Posts
Discussion Starter · #8 ·
So if the consensus says head gasket
Are we going with the Intercooler breaking and filling up with water then pushing the gasket ?
 

·
Registered
Joined
·
2,042 Posts
Well from the sound of things written here, I was assuming the water was coming from the HG and not the intercooler.

Right ???

Your 1st intercooler might still be fine.
 

·
Registered
Joined
·
1,809 Posts
Discussion Starter · #15 ·
These three pics are all from cylinder number 8
I think i just pushed the gasket in two spots
No holes in the heads
Plugs looked good and pistons are pretty carbon covered leading me to believe the 11.2 afr
These are 15$ fel pro gaskets with an o ring in the block
They also were not coated in anything and the motor has been together for 3 years
I'm leaning towards chalking it up to a loss and need to maybe put a better gasket on it
I also can't recall if I ever re torqued the heads after warming it up 3,years ago







This is cylinder two which also showed low on leak down and had coolant


Any suggestions on a better gasket
How bout copper
 

·
Registered
Joined
·
1,809 Posts
Discussion Starter · #18 ·
These aren't copper they are the cheap fel pro perms torque 9333 graphite gaskets
The heads and block are not prepped for an mls gasket
 

·
Registered
Joined
·
642 Posts
so your kinda stuck using the o rings
that setup should hold boost...the 9333 o ringed should work fine
make sure the block & deck are dead nutz flat & true
& make sure your tune is good...& you have good fuel
copper gaskets is race only imo & not for street
 
1 - 20 of 20 Posts
Top