Yellow Bullet Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
This is my first time to run aluminum rods and after 15 dyno pulls tuning a twin turbo efi engine, i decided to take the engine apart just to look at it. There was one rod where i took the rod bolt out and a small almost 3 quarter round (sliver) of aluminum thread came out as i unscrewed it. Is this common ?
 

·
Registered
Joined
·
1,433 Posts
dont think its common, i do know that alot of guys will replace aluminum rods after running them on the dyno if its alot of pulls.
 

·
Registered
Joined
·
2,647 Posts
No that is not common, post a pic if you can,,,, call GRP and talk to them
 

·
Registered
Joined
·
3,558 Posts
I HAVE seen GRP's that had what you describe in the threads new. I always clean them well before assembly. Was this piece very thin ? are you sure it was a thread pulling out?? DID you oil the bolts on assembly??
 

·
Registered
Joined
·
157 Posts
Discussion Starter #6
No cause for alarm, i talked to grp and he told me it was most likely when the steel inserts were pressed into the rod cap it peeled a small bit of aluminum from the pressing in of the insert. . It did come out as just a sliver and did not appear to come from the threads. It also showed up under the rod bolt head anyway when i took the rod bolt out. Couldnt been part of thread then.

I should have called grp first instead of alarming people about this . The rods are working great and great service for grp.
 

·
Registered
Joined
·
263 Posts
I run GRP 5300's and I remember seeing a hair or two as I cleaned them when new. Never thought twice about running them.
 
1 - 7 of 7 Posts
Top