Yellow Bullet Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
LSx 427 still on hydraulic (morel), 50 miles on this motor, few dyno pulls and 1 full pass. Tearing it down to check it out and the cam has grooves like record on it. It is a new bullet cam 63x lift. lifter rollers look fine but the cam is grooving, I can feel them a bit with my nail. First try with Bullet cams, is it done for?

Also the PT88/98 is on a f trim wheel with a .92 A/R. Really laying over at 6500 rpm at 19 psi. I am pretty sure the back pressure is getting pretty high with this small turbine setup.

Should I go 1.3x or 1.00 Turbine with the g trim wheel?

Car only ran [email protected], 7500 Ft DA, 19 psi, car is heavy. She needs a diet and some more horsepower.
 

·
Registered
Joined
·
5,292 Posts
On the lobes or journals?
 

·
Registered
Joined
·
10,843 Posts
98mm turbine? Is that a large frame T6? Anymore information? Man, by the time you change the turbine wheel/shaft, exh housing and rebalance, you're going to be almost half way to a whole other turbo, no?
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
98mm turbine? Is that a large frame T6? Anymore information? Man, by the time you change the turbine wheel/shaft, exh housing and rebalance, you're going to be almost half way to a whole other turbo, no?

It is a T6. 98mm compressor contoured to 88 at the inlet, its a F trim exhaust wheel, don't know how bit that is but I am pretty sure it is really holding us back. The car will lay over on low gear right at 6400-6500 but on 12 psi it will spin clean to 7k. Will just sell this and go to a straight 98 with a g trim turbine wheel, just don't know if the 1.3x A/R will be too big. It comes up really fast now.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #6
On the lobes or journals?

It is on the lobes, even the base circle. It looks like machine marks almost. Was normal shiny when it went in. Wondering if it is a hardening problem. Never seen it before. Didn't hurt anything, lobes look fine just lines that travel the circumference of the lobes, including the base circle. Lifter rollers spin free and look perfect.
 

·
Registered
Joined
·
1,326 Posts
Sean this might sound silly but you may want to consider pulling a oil sample from the filter and sending out for analysis, perhaps its debris cuasing the marks, beside its pretty cheap insurance and it should tell you what is going on internally, It Shouldnt be marking up so quick but Im no expert by far, and have no Experience with Billit sticks. Good luck Hommie!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #9
 

·
Registered
Joined
·
80 Posts
Discussion Starter #10
If it is laying over @ 19psi, however pulls fine @ 12psi, then you may not have enough valve spring pressure on the seat and you are floating the valves.

Chris
We have 165 on the seat and 445 at lift. Stock rocker with 5/16 .080 wall. Just don't see anyone running a turbine this small with a motor this big. Obviously don't want to throw the wrong parts at it.
 

·
Registered
Joined
·
362 Posts
We have 165 on the seat and 445 at lift. Stock rocker with 5/16 .080 wall. Just don't see anyone running a turbine this small with a motor this big. Obviously don't want to throw the wrong parts at it.

I have a LSX427 as well and when it was a hydrallic roller with my
Garret gt55-94 on [email protected] 15psi it was fine, any more than that, it would float valves. Ironicly we had 165 on the seat as well.We changed out the springs and the seat pressure up to 180 and it was fine. We ran up to 22psi. We did not feel comfortable going any higher on the seat than that with a hydralic roller.

Chris
 

·
Registered
Joined
·
80 Posts
Discussion Starter #12
Sounds like that might be our culprit. I will put a pressure gauge on it next time out and see if the small turbine is hurting us, we don't need to go crazy with this setup just need it to run out the back.

Thanks
 

·
Registered
Joined
·
5,292 Posts

Can you feel and ledge with your fingernail going from the area where the roller wheel runs to the other part of the lobe?

That could just be grinding marks that now as the cam is run it polishes it. There is a lot of feel in figuring that deal out.

I agree.... MORE SPRING PRESSURE!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #14
You can just feel it a tiny bit. Bullet says this is normal, they want a bit of friction to keep the roller moving. No worries there. Talked to PAC and they have a spring that will give us 200 on the seat and still clear in the LSx heads. Just need to find out what the Morel's will put up with.
 

·
Registered
Joined
·
5,292 Posts
The lifters will put up with that!
 

·
Registered
Joined
·
1,326 Posts
You can just feel it a tiny bit. Bullet says this is normal, they want a bit of friction to keep the roller moving. No worries there. Talked to PAC and they have a spring that will give us 200 on the seat and still clear in the LSx heads. Just need to find out what the Morel's will put up with.

How did the rest of the motor look?
 

·
Registered
Joined
·
80 Posts
Discussion Starter #17
Motor is looking good so far. Just need to get more spring in her and some more turbine, although I will miss the quick spool of the small wheel/turbine :(
 
1 - 17 of 17 Posts
Top