Yellow Bullet Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
2,579 Posts
Discussion Starter #1
Alright all,

Im stumped on this one. 2004 F-140 5.4 triton. Just recently developed a nasty habit of running rough and wanting to quit as you come up to a stoplight. It will immediately start and run properly like nothing happened. At the higher operating RPM's like on the highway, the truck runs perfect with plenty of power. I have checked all the basics, pilugs, coils and vacumn leaks, and fuel filter. everything checks out good. anybody experienced this before? and how was it corrected. also, no codes are present. damn thing is driving me nuts.
 

·
Registered
Joined
·
2,377 Posts
3 valve or 2. Has it thrown a code? if not i'd get it scanned anyways. they dont always throw a check engine even if it has a code
 

·
Registered
Joined
·
2,579 Posts
Discussion Starter #5
Its the 3 valve. cleaned the throttle body with no change. keep em coming, im about to torch the damn thing.. lol
 

·
Registered
Joined
·
5,680 Posts
Fuel pressure regulator ?
 

·
Registered
Joined
·
1,122 Posts
IAC could be gummed up and moving slowly.
Check all the hoses to the PCV and make sure they are not collapsing under vacuum or have a hole in it that only leaks sometimes. I've had to take the whole line off where I could see
all of it.
 

·
Registered
Joined
·
2,649 Posts
Don't those have a MA in the airbox or after? Might want to value that also. IAC also and vacuum leak as others said.

Does the truck do this only on the highway when coming to a stop? Do some city driving once and if it stays running might be a Converter lockup on its way going out.
 

·
Q(t)=ṁCpΔT
Joined
·
28,142 Posts
IAC might hanging up. When they eventually, go they just stop moving.
 

·
Registered
Joined
·
615 Posts
is it high miles? does it have any rattle noise when it runs bad..if so check base oil pressure hot at idle..low pressure will screw up the chain tensioners and phasers causing stall and rough running....I had 3 that ran like crap and the maf and baro was perfect..cleaned the maf and fixed them
 

·
Registered
Joined
·
1,326 Posts
Check the rubber hose going to the pic valve. They get soft and break all the time
 

·
Registered
Joined
·
262 Posts
Need to hook a scan tool up and see what the fuel trims are and see what hz the mass air flow sensor is reading. It should be above 150hz. Biggest thing is check it good with a scan tool before you start throwing parts at it.
 

·
Registered
Joined
·
2,377 Posts
I dont think any of the 5.4 3 valves have mass air. If it was a oil pressure/cam phaser issue it would make all kinds of rattling noise when started cold and sound like a diesel. Does it rattle right before it cuts off ? Spray carb cleaner all over the engine especially around where the intake meets the head. See what happens
 

·
Registered
Joined
·
782 Posts
Like others said, scan tool to check fuel trims + also check the mode 6 data for misfire counts
 

·
Registered
Joined
·
686 Posts
I'd bet low oil pressure.
We had one doing this and that was the problem. The truck sounded like shit idling. Dad parked until we could fix it and noticed it was leaking oil at timing cover. Long story short tensioners/guides failed and came apart, chains rubbed a hole in timing cover and all the plastic shavings clogged the pickup. It was a mess but replaced everything and jb welded the cover and hit the road.
 
1 - 20 of 29 Posts
Top