Yellow Bullet Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Made it out to the track for the first time friday night with 30 min of run time on the engine and hardly no tuning. Race weight with me in the car is 2960 and I weigh 200.

combo: pump gas
stock lq4 shortblock with arp rod bolts
local hand ported 243's, milled .040, valve job, stock valves
.051" head gasket, stock lifters, stock rockers, ls2 hd timing set
comp 238/246 .605/.614 110+2
stock water pump
victor jr intake, 850 carb, 1 7/8 dynatech headers
th400, 10" tci (for now), 4.10's, 26x8.5 slicks.

First pass with the rev limiter set at 7000, running out of gear around 1100ft so I coasted to the finish.
1.52 60' left at idle
[email protected] 1/8
[email protected] 1/4



Second pass went up in jet size and set the limiter to 7300, still on the limiter about 100 ft before the finish.
1.47 60' left at 2000
[email protected] 1/8
[email protected] 1/4



Third pass were same conditions as 2nd pass.
1.46 60'
[email protected] 1/8
[email protected] 1/4

All in all I am very pleased with these shakedown passes. Going to put a 28" tall tire on it so we can do some fine tuning to the motor and not have to worry about spinning it too high.

Lance
 

·
Registered
Joined
·
4,488 Posts
Looks good.

Get those few things fixed and you will be flying for sure.

Tim
 

·
AMP Racing member
Joined
·
3,492 Posts
LSX powered notch - very nice! Looks good and is fast. Congrats!
 

·
Registered
Joined
·
77 Posts
Discussion Starter #6
Thanks y'all!

the passenger side headers went in no problem. had to massage the drivers side because of the steering shaft and frame.
running the factory tank sumped with a holley blue pump and regulator. pressure between 6 and 7psi.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #7
also one thing i am having problems with is the expansion tank for the coolant. after a full run the engine temp gets to 200, this is with just the water pump turning with no efans turned on. make it back to the pits and there is a pin hole on top of the tank spitting hot water out. this is with running a 160* t-stat and i have the rear steam ports blocked off like factory and the front ones ran to a fitting on the water pump.
 

·
Registered
Joined
·
4,488 Posts
My fan is controlled by a Spal controler and I see 200 but is back to 190 by the time I am back to the pits

Tim
 

·
Registered
Joined
·
5,292 Posts
Put the limiter at 8K and let it eat... only thing that will prevent it from going up there is the valvetrain stability. The Q4 with rod bolts will take it.

Nice setup... love LS motors in Fox drag cars.
 

·
Registered
Joined
·
3,014 Posts
blocking the back steam ports off is not great. get a ls1 style crossover(H shape) it will help calm the hot spots in the back down. Or get one of the bleader kits that let you run an line from each corner to the radiator. 200 is hot for just a 1/4 pass. Why not run the fans to keep it cooler? what radiator?
 

·
Registered
Joined
·
20,215 Posts
with the thermostat on the return hose, those things get a lot of air trapped in them-i usually fill by way of the top hose, and take the steam line into the radiator
nice MPH if you were not making it to the end
 

·
Registered
Joined
·
77 Posts
Discussion Starter #20
blocking the back steam ports off is not great. get a ls1 style crossover(H shape) it will help calm the hot spots in the back down. Or get one of the bleader kits that let you run an line from each corner to the radiator. 200 is hot for just a 1/4 pass. Why not run the fans to keep it cooler? what radiator?
i understand what you are saying but this is how it was set up from the factory so i left it. i haven't ran the fans much because i don't have an alternator and i don't trust the stock gauge. just installed an autometer volt gauge today. i don't know what radiator it is, it came with the car and they were running an sbc before me.
 
1 - 20 of 38 Posts
Top