Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
776 Posts
Discussion Starter #1
Well I finally made it back to the track with my sleeper. Less then stellar outing, but I am just happy it’s running again!

Ditched the home ported iron heads, POS intake, and 224/[email protected]" for a set of CNC'd eddelbrocks and a Lil John cam, victor Jr. intake.

Added on-board air to controll the gate, and went from a 3.23 to a 3.55. Added a pair of Menscer DA shocks and mono-leafs to the back, to go with my 10" rims (from 7"), and AFCO DA's to the front too.

S475, non-IC E85, 367", 3700 lbs.

On to the Runs...

Pass 1 – 3300rpm 5psi launch, 7.5psi down track, 16 degree’s timing. [email protected]

Pass 2 – 3300rpm 5psi launch, 7.5psi down track 20 degree’s timing. [email protected]

Pass 3 – 3300rpm 8psi launch (commanded but realized later that it wouldn’t make 8psi at 3500), 7.5psi down track 24 degree’s timing. [email protected]

Pass 4 – 3500rpm launch 8psi (commanded but realized later that it wouldn’t make 8psi at 3500 either so maybe 6psi?), 9psi down track [email protected] 1.62 60ft.

Pass 5 – Wouldn’t run. Thought the air tank was empty?

Pass 6 – Wouldn’t run again. Air tank not empty, but found it loosing pressure like crazy.

At that point I realized that the brass “t-fitting” broke off the top of the wastegate? I’m guessing it was over tightened/stressed/cracked or something. I actually had an extra with me, but unfortunately didn’t have an easy out. Fortunately the guy next to me did, so I was able to repair it.

Pass 7 – Same tuneup as Pass 4. [email protected] Sort of strange that the MPH was down.

Pass 8 - Realized the reason it wasn’t making a bunch of boost on the line was because the 2 step was too low… it wasn’t the boost controller’s fault. So I upped it to 4000 rpm, and added boost down track to 12psi as well as some timing. Blew the tires off at the hit because now it’s making a ton of RPM/boost. Got back into it and ran it out the back door. Still only made 9~10psi and went 124mph (I’m guessing it would have gone 125’ish on a good pass, so it liked the timing from pass #4 on 10psi).

That was it for the day… track was shutting down.

When I got home, I realized that at least part of the reason it wasn’t making boost down track on the last few passes was because I forgot to tighten the clamp that holds the two halfs of the wastegate together after I fixed the fitting. It was just finger tight, so I’m sure it’s leaking there.

Need to get some soapy water and figure out where the wastegate airtank tank is losing everything.

It spools pretty slow too on the line… gotta figure out how to get some fuel out of it on spool up because it’s just way to fat to light the turbo (A/F is down around 10.0:1). Might make it REAL hard to bracket race if I can’t get that fixed… lol

All and all, it’s not a rocket yet… but considering I actually only got 4 clean passes where everything was working, and picked up a full second in ET and 11 mph with just some minor tweaks… I guess I can’t complain too much.
 

·
Registered
Joined
·
49,830 Posts
swing by the shop tonight and I will give you a piece of aluminum 1 3/4 where your upper hose goes over the down pipe, before you drive over the cooling system contents.
 

·
Registered
Joined
·
9,666 Posts
11 mph gain posted on the first outting.... Not too shabby....

We need to look at taking main jet outta the carb and putting the fuel in with the high speed air bleed.... maybe that will get it lean enough to quit drowning the motor during spool up.
 

·
Registered
Joined
·
776 Posts
Discussion Starter #10
My carb guy told me to take 3 jet sizes out of the primary, and put 3 back in the secondary. I'll try that first... It does have a BRPV in it, but it's even before boost comes on that it's fat.

I only ended up at like 9psi and 20'ish on the timing. I know it needs more... heading back out this Friday.
 

·
Registered
Joined
·
2,198 Posts
My carb guy told me to take 3 jet sizes out of the primary, and put 3 back in the secondary. I'll try that first... It does have a BRPV in it, but it's even before boost comes on that it's fat.

I only ended up at like 9psi and 20'ish on the timing. I know it needs more... heading back out this Friday.
Whose carb is it? Is the brpv adjustable? Are you sure its not opening way too early? Its a night and day difference when you get the power valve adjusted correctly.
 

·
Registered
Joined
·
776 Posts
Discussion Starter #12
It's Eric's carb from HP innovation. He suggested the BRPV might be opening early too. I have some different springs that I can swap in to adjust it, so we may do that next.
 

·
Registered
Joined
·
49,830 Posts
1 - 13 of 13 Posts
Top