Yellow Bullet Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
716 Posts
Discussion Starter #1
Since recently switching to 550 atomizers from a set of 225 siemens dekas, i have noticed a large swing of over compensation in my closed loop corrections at full throttle... i havent ever really messed with the gain tables before, but i dumbed it down from 40 to 30 and it seemed to help quite a bit, but im just wondering what guys have lowered the values to and had success at? i know its an obscure question, but if anyone has experience with this that would be cool! thanks!
 

·
SO MUCH TIMING CHAIN!
Joined
·
1,135 Posts
Does FAST have a 8A driver?

These BIG injectors need a large driver so they can have predictable opening times.
i spoke to mike when i bought his 550's, and he said the fast xfi would have no issue with his injectors. i was also worried about the drivers
 

·
Registered
Joined
·
716 Posts
Discussion Starter #8
Yeah the XFI has been sent back for the saturated injector driver update as well as additional power and ground upgrades to the harness... They seem to work really well so far.... I already knocked the lower end to 5, I'll knock the upper gain to 10 and try it next time out! Thanks for the responses!
 

·
Registered
Joined
·
2,601 Posts
How fast did you run on your 225lb injectors? What fuel pump did you run? I am running 160lb injectors...looking at siemen deka or the billet atomizers. Need to figure out what fuel pump to run. I don't know how I am going to get another pulley/gilmer pulley on the front.
 

·
Registered
Joined
·
716 Posts
Discussion Starter #10
I made it as far as 22psi boost at 90% duty cycle using 90psi base pressure with an aeromotive tower regulator and a red aeromotive belt drive pump.... anything more than this and i had a secondary nozzle injection system that had a NOS solenoid that was progressivly pulsed on from the hit in which is added extra fuel to the inlet pipe... i was able to run 29psi boost and the times in my signature with that setup but found that it lacked control of cylinder trimming for the poor distribution of that nozzle.. so hence why i switched to the 550 atomizers and now im at 45% duty cycle at the same level!
 

·
Registered
Joined
·
2,601 Posts
Wow....are you running a waterman or weldon cable/belt drive? Any issues with your atomizers? Thanks, Greg
 

·
Registered
Joined
·
716 Posts
Discussion Starter #12
I'm currently running a black aeromotive belt drive pump .... It's working well for now ! I haven't had any issues with the billet atomizers other than needing a bit more after race maintenance (drain methanol and fill with gas and run for a few mins so the methanol is flushed out while sitting)
 
1 - 12 of 12 Posts
Top