Yellow Bullet Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
127 Posts
Please keep us updated on this. I'm in the same boat. I went out this weekend for the first time running the Biondo RPM-1 rpm switch and dedenbear electric shift solinoid. It shifted as soon as I released the TB button also. I set it to shift at 3500 and it did perfect in the pit area, but I set it at a 6800 shift point and it shifted when I rev'd it to 5000 in neutral a few times. I assumed it was my OBD2 signal from my PCM since it's on a 2001 Camaro.

I too had to remove it and shift manually.

I'll let you know what I find if I get it figured out also.
 

·
Registered
Joined
·
127 Posts
I spoke with a guy at Digital Delay, the manufacturer of the RPM 1shift controller and he said my problem was probably due to vibration or shock within the car at the launch since I was using the NC to fire the shift solinoid. He said the contact springs inside the controller are not real rigid and can make contact under a shock load situation like a wheel stand or TB launch.

He recommended using a Bosch relay to reverse the current and use the NO out put to fire the shift solinoid. He said it was a common problem and that has fixed each problem that he has seen.

That's fine and dandy, but I have no inkling how to wire in a Bosch relay like he is describing.

Can someone offer a drawing showing the wiring diagram needed to accomplish this? The original install is cake even for a green horn like myself, but he lost me at relay.lol.

Thanks guys!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top