Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
302 Posts
Discussion Starter #1
Is the water pump just above the belt tensioner on pass side motor? if so,it is making some noise and pulley looks like it wobbles. big job to replace? also is there a trick to getting one of the V clamps back on the turbo? cant squeeze hard enough to get nut started. THANKS!
 

·
Registered
Joined
·
351 Posts
Whatever "pulley" has two bolts next to it is the water pump. Make sure you use a sprayable gasket sealer to the rubber o-ring or it will leak again. Easy job to replace. 30 min tops with plain old hand tools.

I have never taken the nut off the v-bands to get them to release from the flanges. So they go back together very easy. I would just break the flanges again, put the nut back on and snaggle it back in.
 

·
Registered
Joined
·
5,680 Posts
If you can't figure out those two on your own, maybe a proffessional would be the best route ............
 

·
Registered
Joined
·
42 Posts
Very simple job... Two 10mm bolts hold it on. You don't have to remove anything to change it other than the belt. They are a terrible problem replaced literally hundreds of them.
 

·
Registered
Joined
·
8,489 Posts
Easy G racer just a question.YIKES!
He might not be acting like an asshole. You'd be surprised the kind of questions that get asked.

I answer questions on wikianswers every day, and they ask questions that are so incredibly stupid that they could not possibly be thinking about opening the hood unassisted.
 

·
Drag Week Survivor
Joined
·
14,409 Posts
Easy G racer just a question.YIKES!
Gameracing made a perfectly reasonable statement.


If you cannot tell a idler pulley from a water pump, then take it to a professional. Honestly, your question could have been answered in 5 seconds by using google, but you chose to post it in TOBT so now you have to live with people calling you a dumbass. :p
 

·
time to go racing yet ?
Joined
·
33,782 Posts
dont forget to drain the coolant ................... unless its like mine ..... 1 time it exploded and pitch the belt and fucked some shit up ..... another time it just leaked alot out of the weep hole ............... yup 2 water pumps in less than 70k miles ............ they say its becuase of the early blocks had alot of silica in them and ruins them .....
 

·
Registered
Joined
·
1,875 Posts
Buy two and keep one in truck for future use .Cause when they give up,your ass is on side of the road until you get one.Lucky it a easy repair .
 

·
Registered
Joined
·
302 Posts
Discussion Starter #13
In no way do I think any response was that of a A hole. I am thankful for ALL responses. This site provides a vast amount of great advice!When I posted that question I was pissed off and not thinking straight. Jim J i/e 482nova.
 
1 - 13 of 13 Posts
Top