Yellow Bullet Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,213 Posts
Discussion Starter · #1 ·
on jack stands the converter went to 6200 on the brake and now it will only allow 3600 on the brake, The car did not move between "tests"
 

·
Registered
Joined
·
181 Posts
It's pretty hard on the converter when you do that I've been told.If I remember correctly its hard on the sprag in the converter. Don't take too much to heart just flappin my lips. Congrats though on gettin the car done!!
 

·
Registered
Joined
·
2,917 Posts
Let me know Scott - if I can help! Doesn't sound good.

Hope all is well otherwise. Impressive numbers at the track!!!.. I think I am gonna have to build something bigger!!! #[email protected]%!!!!

Oh.. talk to Randy about the quality tranny you have. ;) Should make you feel at-ease in abusing yours...

Might be heading to Mission Sunday to watch Randy make a few hits..

Take care!
 

·
Super Moderator
Joined
·
19,736 Posts
You may have broken something but it may just be a coincidence that it seemed to lose stall when off the jackstands. If you are doing testing on the jackstands , just don't let off the transbrake button with the wheels unloaded , thats what kills parts.
I would have the converter checked.


Hutch
 

·
Registered
Joined
·
3,213 Posts
Discussion Starter · #5 ·
You may have broken something but it may just be a coincidence that it seemed to lose stall when off the jackstands. If you are doing testing on the jackstands , just don't let off the transbrake button with the wheels unloaded , thats what kills parts.
I would have the converter checked.


Hutch
oops!
so I will swap convertors. I thought I did something to the motor!

Thanks!
 
1 - 5 of 5 Posts
Top