Yellow Bullet Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I have a dedenbear p/g case that has the transbrake adjustment bolt with numbers on it ,on the back of the case, what does that adjustment do.When the transbrake is appiled the car rolls forward. where do i start to fix this problem??
 

·
Read Only
Joined
·
0 Posts
Loosen the jamb nut and tighten the screw to 70-72 inch/pounds. Back the screw out 3½ turns for Dedenbear and JW cases, 4 turns for stock cases
 

·
Super Moderator
Joined
·
19,740 Posts
I have a dedenbear p/g case that has the transbrake adjustment bolt with numbers on it ,on the back of the case, what does that adjustment do.When the transbrake is appiled the car rolls forward. where do i start to fix this problem??

The rear bolt with the numbers on the head is the transbrake flow rate valve. If its all the way in , the transbrake will set up slow and release slow. If its all the way out ( 7/16" out from all the way in approx) it should setup faster and release faster. I don't really do much with that system other than just run it wide open.

Let me know what you have, Hutch
 

·
Registered
Joined
·
4 Posts
I am having the issue of the car just moving back a touch when I apply the transbrake. Caused me to back out of the beams a couple of times this weekend. I adjusted first gear band to 3 turns out cold but I still have the problem. Mine is a JW glide. I like to stage shallow so what should I try next? Can I use the brake adjustment bolt to help with it?
 
1 - 7 of 7 Posts
Top