Yellow Bullet Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4,156 Posts
Discussion Starter · #1 ·
I have an old(er) Snap On YA 205A MIG Welder that I need the front / top circuit board w/ control knobs for. Evidently Lincoln Electric is now the owner and in control of replacement parts for these. Is anyone here a dealer for them ?

I have used this welder since 1988 and owned it since 1992 ( bought from original owner ). I spent 500$ on it about 1 1/2 years ago and hate to get rid of it. I like it because it holds the big 44 lb. wire spools. It worked great 4 weeks ago, then 1 of the pods on this circuit board acted up but I got it to work ... Yesterday it failed again and I cant get aything other than an occansional " clunk " out of it when turning the " Mode " knob which has corrosion on it and is soldered into the board.

The Part # for the board I need is " 880-114-666

It has a Customer / Catalog # of 510-074-000
-------------------------------------

On Lincolns website the closest part # to mine that I foind is " 880-113-666 ... and it has the same description.

TIA
 

·
Registered
Joined
·
21,141 Posts

·
Registered
Joined
·
4,156 Posts
Discussion Starter · #4 ·
Duane- I cross ref'd that number to Century welders (lincoln made) and got this link

http://www.lincolnelectric.com/assets/ServiceNavigator/Century/Main/Century Circuit Board Index.pdf

I also have ordered parts from this guy and have never had a problem.. http://WWW.WELDER-PROS.COM

If you continue to have a problems I can go "junking" and see if I have anything that will cross up....
Jeff .. Thank You !!! Thats the same site I was looking at. Printed out a exploded view of the top of the machine.

Would it help if I took a picture of the board the " suspect " pot ( 3 position switch )
 

·
Registered
Joined
·
4,156 Posts
Discussion Starter · #5 ·
Duane . you might want to check the pot first also, just to make sure it isn't something simple..
Odds are its in the Pot, how do I check it ..... it has greem corrosion on one terminal. I did the best I could to clean it.



Complete Board




Problem Child




Board Pic w/ bad switch on far left


wire plug and bad switch



Wire Plug

 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top