Yellow Bullet Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter #1
I'm having trans and converter issues and trying to figure it out. I'm running a ford C5 with a C4 ATI full man VB.My new converter and trans worked awesome at first but lasted a few hundred miles until major slippage like 25% at the finish line. I replaced the converter with a used one and it seemed better until a few miles again and shifted funny and seemed to slip but not as bad, blew fluid out the vent at the track,so i removed it all and just tore the trans apart to find nothing wrong other than fine metal filings and a old hard servo seal. The converter is going back for inspection as i think the stator has issues. One thing i noticed is the stock pinto converter i replaced original custom one with has .075 smaller converter pilot to the crank and it's .200 longer and i think it's to loose and possibly from a 2.0 ford not a 2.3 like i have and is too small? would this cause problems? Just trying to find a solution as both my converters are full of crap and possibly trashed and the new trans needs cleaned and rebuilt. Thanks much!
 

·
Registered
Joined
·
893 Posts
if the hub is too small it wont be centered and the converter will whip the piss outa the tranny.i'm no trans builder but i've been there n done that.:cool:
 

·
Registered
Joined
·
781 Posts
You need to look at the pilot very carefully for size and fit..
Those little 10" ford converters have a tendency to balloon easily in their stock configuration which can cause slippage in the converter...
Also look closely at your filter for whats in it. Been seeing a lot of c4 filters getting plugged up lately> this would give you slippage from the trans/ burnt clutches....
 

·
Registered
Joined
·
232 Posts
Discussion Starter #4
I can't find any real issue in the trans other than the old hardened servo seal and the very small debris. I think the converter that fit real loose to the crank is a 2.0 one and it is getting tossed as it's full of crap now anyways. I'm starting to think that metallic trash ruined the second converter in quick order plus the small pilot didn't help at all. The screen filter in the pan looks pretty clean and the little round tapered screen in the pump feed hole is real clean.
 
1 - 4 of 4 Posts
Top