Yellow Bullet Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I`m hoping someone can help me out with a 98 cavalier 2.4 4cylinder I`m working on, it has a 100,000 miles on it and it runs great except at idle it will miss on all 4 cylinders, the only codes it will throw is a p0300 and as soon as you pick the idle up to 900 rpm or more it clears up and runs good, there are no vacuum leaks, but it only has 14 inches of vacuum with the needle on the gauge buzzing back and forth like a hummingbird on crack. I installed a new intake gasket, and checked the intake for cracks. It has 175 psi cranking compression in all cylinders and when i pressurize the cylinders they are airtight, I`m starting to think the exhaust cam has jumped a tooth, but its a chain and it runs really good. Anyone run into this or have an idea what it could be?
 

·
Registered
Joined
·
266 Posts
Sounds like valve timing issue, had the same situation on a 2.4 before, someone did a waterpump and had the exhaust side off a tooth, misfire at idle, low vacuum, but would clear up above 1500 rpm. hope that helps
 

·
Registered
Joined
·
381 Posts
could the chain have stretched that much for the cams to be out of time with each other? seen it before on a nissan. causing the 300.
 

·
Registered
Joined
·
409 Posts
Hate to be the bearer of bad news but if the vac guage is bouncing it HAS to be mechanical. A vac leak, ign problem....cannot make the vac guage bounce. I would think valve timing issue also.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
Sounds like valve timing issue, had the same situation on a 2.4 before, someone did a waterpump and had the exhaust side off a tooth, misfire at idle, low vacuum, but would clear up above 1500 rpm. hope that helps
Ding Ding Ding! I think we have a winner! Long story short, the people have owned the car for 3 months, the woman who dropped off the car said "it just started running badly". The kid who drives the car daily, just told me today its been running bad the whole time they`ve had it. The timing cover has been off in the not to distant past, but not since they`ve owned it. So I`m thinking the same as you, someone put in a waterpump, fucked up the cam timing and sold the car to these people. Things make a lot more sense when people tell you the whole story! Thanks for your help!
 

·
Registered
Joined
·
368 Posts
That motor has multiable tensioners on both chains that that motor uses , tensioners on one chain is like 8" long piece of plastic on both sides of the chain . So could be many options with that timing . *** I have been working on a lot of 2.2 4 cylinder caviliers 95-2003 and they have random miss fire at idle with the valves needing to be taken out and cleaned .They have so much deposite build up that they cause misfire at idle ,then during driving few misfires .Snap on computer will zero in on this problem your having ,that is what I use the 2500 brick computer updated to 2005 .Good luck - get prices on the parts and gaskets for the job the prices may shock you .
 
1 - 11 of 11 Posts
Top