Yellow Bullet Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Car was running 4.30 last year unloaded this year it goes in high gear and lays over.706 with powerglide On nitrous it blows intake apart, on motor its obvious it goes into high gear and sounds like you hooked a chain to it, so thought we had ignition problems I have changed, the box, coil and wire, battery, fuel pump, distributor and cap, plug wires, took carbs apart 3 times replaced floats needles seats, took converter apart and looked great! Dont know what else to try help needed!
 

·
Registered
Joined
·
1,224 Posts
T-flow is right, it could very well be your springs. The more the load, the more the symptoms show up.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
We checked springs,not one is weak......took converter apart looks great,tranny seems fine no visible signs there either! Any other ideas?
 

·
Registered
Joined
·
20,001 Posts
What's the plugs look like check and varify the timing again
 

·
Registered
Joined
·
4,181 Posts
I know it seems like a pain in the a** but.

How do you know the converter is good? You had cut it apart?

Whats the spring pressure?
Stainless valves?
Titanium retainers?
 

·
Registered
Joined
·
20,001 Posts
The spark plugs will tell you everything.....it is a timing or fuel problem as you stated.... it blows the intake apart also.

Check the trans, make sure the band is not glazed or not releasing going into high...Captian Obvious would say that's the problem typically, but not in your case as it wont run on NOS either.
 
1 - 14 of 14 Posts
Top