Yellow Bullet Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
I HAVE A BASICALLY STOCK LQ4 SHORT BLOCK WITH ARP ROD BOLTS, IT HAS L92 HEADS THAT HAVE BEEN SHAVED 0.40. IT HAS A VICTOR JR INTAKE AND A TEXAS SPEED CAM (612 LIFT). DO YOU GUYS THINK IT WOULD LIVE WITH A SMALL CHEAP TURBO SET UP ON IT?
 

·
Registered
Joined
·
1,427 Posts
CAPS LOCK BROKEN???
 

·
Registered
Joined
·
957 Posts
L92s shaved .040? They have a sealing issue with stock deck thickness... Taking .040 off isnt gonna help that.
 

·
out of work hair dresser
Joined
·
8,341 Posts
L92s shaved .040? They have a sealing issue with stock deck thickness... Taking .040 off isnt gonna help that.
How much of a sealing issue do they have?
 

·
Registered
Joined
·
716 Posts
Put 10psi to it and it shouldnt be anywhere near a problem, is that all you're looking at? You said small, small will work, 10psi is pretty small. I have a stock LQ4 with stock 317 heads and it works on 16psi so no reason at least 10psi wouldnt work on your shaved L92 setup. Im near Easton btw.
 

·
Registered
Joined
·
49,441 Posts
I'd ditch the cam but the heads should be ok for 10-12 psi of boost with little to no trouble. But your mileage may vary.
 

·
Registered
Joined
·
3 Posts
L92s shaved .040? They have a sealing issue with stock deck thickness... Taking .040 off isnt gonna help that.

my heads were shaved .040 when my L92 was NA. zero sealing issues i ended up trading the shaved heads for unshaved ones to turbo the L92
 
1 - 8 of 8 Posts
Top