Yellow Bullet Forums banner

1 - 2 of 2 Posts

·
Senior Member
Joined
·
3,084 Posts
Discussion Starter #1
..got the car back together with a bigger-better set of heads, intake and forward facing 2" headers. Same blower, cam, lifters, CID, compression, etc. BS3, 7531 so on.

I rebuilt the transmission due to a failure in the pump bushing that supports the drum, which wiped out the high gear clutchs. I replaced the drum with a rollerized steel 8 clutch set-up, shimmed the end play to .010", reused the 1.80 gearset, input shaft, cleaned up the VB and replaced the pump with a stocker that I drilled for better lubrication the the bushing. The pump I used also had a pressure valve in the port beside the cooler bypass that my old pump didnt hve so I removed it.

Since the car was back together it will not pull any RPM in high gear. On the dyno it has dropped from 7300 to 6200 and getting worse with each pull. At the track it would flash at 6000-6200 as usual then pull to 7600 in first, on the gear change it dropped about 1000 RPM. pulled back the about 6900-7000 then flatlined and would not pull any higher to the eigth.

Convinced it was a bad converter (that I had converted to spragless) I tried a different 8" converter. It flashed to about 5500 and did the same exact thing on the dyno.

upon inspection of the converter I removed it had a galded area on the hub the same distance down as the bottom of the pump tangs. So I jerked the trans and sent it to someone else to look at....(havent heard back on that yet)

Just trying to figure out where I messed up and if this is my issue?
I have read on here about pump, drainback and pressure issues causing converter problems but I dont know if this is that? The fluid looked great, didnt smell and the trans shifted and brakes perfect!

WTF?!:confused:
 

·
Registered
Joined
·
129 Posts
pump mods. on a pg you here about is enlarging the conv. charge hole.if the conv. stalls the same w/new heads, sounds like you didn't get much power increase. if the t.c. is pulling strong on bottom end of track, it should work on top end.abad t.c. useally goes the other way. turns high rpms but car slows down. but not always! sure hope its not the new heads....
 
1 - 2 of 2 Posts
Top