Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter #1
I have a C4 trans that makes a buzzing noise shifting from park to 1st or back to park or to nuetral to reverse etc.
this noise was there before my trans guy went through it and it is still there.I was told it could be the pump or it could have air trapped or be low on fluid.Other than that the trans shift perfect no slipping
Have anyone of you had this problem.the trans is in the car for 3 yrs now and it drives me nuts.
Thanks
 

·
Registered
Joined
·
215 Posts
Discussion Starter #2
It buzzes for a few seconds then stops but if you shift it back from 1st to park it buzzes again and then stops
 

·
Registered
Joined
·
781 Posts
Possibly the pressure regulator or boost valve. What type of filter and pan is on this unit?
 

·
Registered
Joined
·
215 Posts
Discussion Starter #4
It is a PA deep aluminum pan and for a filter my local parts guy said to use one for a 70s truck because it has the extension for the filter to sit deeper in the pan.

Thanks
 

·
Registered
Joined
·
781 Posts
The only deep filter I can think of is from a Pinto with a C4....which extended down maybe 2 inches or more, I dont recall the exact depth. If your filter is only a 1/2 or 1 inch try to find a pinto filter....
C6 truck filters had an extension......
 

·
Registered
Joined
·
215 Posts
Discussion Starter #6
My bad.i worded it wrong .
It has had the filter with the extension before and after it getting fresshen up.The filter I used it was from a 70s c4 truck application
 

·
Registered
Joined
·
215 Posts
Discussion Starter #8
yes it does extend into the pan.
 

·
Super Moderator
Joined
·
19,365 Posts
If the trans works well it just a regulator noise (no big deal). I would think if the pump was garbage , your trans guy would have replaced it during the rebuild.


Hutch
 

·
Registered
Joined
·
215 Posts
Discussion Starter #10
Hutch it has been 3yrs since he rebuilt it and it worked fine before and after he went through it.
Its just been one of those things that bugs the shit out of you..lol and I figured I would put a post and see what you guys might think it is..
I only hear the buzzing when the car is sitting ,not driving or racing.
If it is a reg. is it hard to change out and where would it be?

Also I have a aftermarket PA dipstick.are they accurate where the add and fill marks are compared to stock?
Thanks for your help Left 4 dead and Hutch :)
 

·
Super Moderator
Joined
·
19,365 Posts
Looks like its going to continue to drive you nuts!! The only way to make it go away may be to change to a different style of valve body that uses a different design regulation system.


Hutch
 

·
Registered
Joined
·
781 Posts
Hutch it has been 3yrs since he rebuilt it and it worked fine before and after he went through it.
Its just been one of those things that bugs the shit out of you..lol and I figured I would put a post and see what you guys might think it is..
I only hear the buzzing when the car is sitting ,not driving or racing.
If it is a reg. is it hard to change out and where would it be?


Thanks for your help Left 4 dead and Hutch :)
It is in the design of the valve body oil circuit of that particular valve body! You would have to replace the whole vb from a different manufacturer
 

·
Registered
Joined
·
215 Posts
Discussion Starter #13
LOL
I installed the VB from TCI before my trans guy went through ,makes alot of sense now.
Thanks again guys for your help
 
1 - 13 of 13 Posts
Top