Yellow Bullet Forums banner

Which system do you prefer?

1 - 20 of 28 Posts

·
Registered
Joined
·
200 Posts
Had mine fur 2 years and still can not get it to work proper.every time I call I get a new set of instructions .costumer service sucks if you don't have a big name.I will never purchase another big stuff.I spent 2500 chasing last problem with no luck it's been sitting in the trailer for 2 weeks.
 

·
Registered
Joined
·
1,403 Posts
Discussion Starter #4
Had mine fur 2 years and still can not get it to work proper.every time I call I get a new set of instructions .costumer service sucks if you don't have a big name.I will never purchase another big stuff.I spent 2500 chasing last problem with no luck it's been sitting in the trailer for 2 weeks.
Which do you have?
 

·
Registered
Joined
·
692 Posts
Don't leave out Accel DFI Gen VII or Motec. I personally like Accel DFI. Either way all of these EFI systems can get the job done!
 

·
Registered
Joined
·
2,379 Posts
neither 1....!!! i like carburetors!!:-D......just kidding, they both really well......and both have their issues.....buy what your tuner will be happy with..!!!:cool:
 

·
Registered
Joined
·
344 Posts
XFI for me.

I like it because it is very easy to learn and good value for price.

Had a problem with windows vista and the USB adapter but that is it. Both are good at doing the same thing.
 

·
Registered
Joined
·
3,676 Posts
I've had my XFI for 3 years now without an issue. Great system.
 

·
Registered
Joined
·
2,107 Posts
BS3 .... works fine for me. Easy to tune and they are very popular. Easy to find help in the pits if you need it. The only bad thing that I think sucks about the BS3 is they use a 9pin serial connection for data transferes. Most PC's dont even have a 9 pin connector and I cant get my current laptop to work with a serial cable adaptor....so that sucks in my opinion. I have to have an older laptop.
 

·
Registered
Joined
·
2,627 Posts
Had mine fur 2 years and still can not get it to work proper.every time I call I get a new set of instructions .costumer service sucks if you don't have a big name.I will never purchase another big stuff.I spent 2500 chasing last problem with no luck it's been sitting in the trailer for 2 weeks.
who did yo buy it from? ebay? no wonder customer service sucks. ....... but you saved $100!
 

·
Registered
Joined
·
936 Posts
Any of the ECU's named would do a fine job.

Installation errors account for the #1 problem guys have with them. I know I've made some.

#2 is that they never learned how to tune them and relied on someone else. The slightest issue and their lost.

I ran a Haltech E6K for years open loop and it ran as great as my tuning ability was at the time.

I run XFI /XIM now and am real happy with it.
 
1 - 20 of 28 Posts
Top