Yellow Bullet Forums banner

1 - 2 of 2 Posts

·
Home of DMX
Joined
·
1,456 Posts
Discussion Starter #1
I have a LS1 F1A with 38 top and 77 bottom 8mm 160 teeth 30mm wide belt. 24psi boost max spinning the engine 7000rpm, have a big red open blow off.
Went to the texas mile this weekend and had nothing but belt trouble. It was shearing off all the teeth on the belt and looked to be doing it at the gear change. It has a fixed idler and the bracket is suported so no bracket flex. Unit is new and oil is still clear. The belt is only 30mm wide because of the ATI cog balancer is only that wide.
Any Ideas on what is happening or has anyone had this problem?

thanks
Doc
 

·
Registered
Joined
·
870 Posts
I have a LS1 F1A with 38 top and 77 bottom 8mm 160 teeth 30mm wide belt. 24psi boost max spinning the engine 7000rpm, have a big red open blow off.
Went to the texas mile this weekend and had nothing but belt trouble. It was shearing off all the teeth on the belt and looked to be doing it at the gear change. It has a fixed idler and the bracket is suported so no bracket flex. Unit is new and oil is still clear. The belt is only 30mm wide because of the ATI cog balancer is only that wide.
Any Ideas on what is happening or has anyone had this problem?

thanks
Doc
Doc, I think I still have an older bracket that used with my F1A, it's for a 8 rib belt-but I made 900 rwhp with it and ran 9.60's lifting.

Your gonna have to go back t o 8 rib but your more than welcome to try it out.
 
1 - 2 of 2 Posts
Top