Yellow Bullet Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,822 Posts
Discussion Starter · #1 ·
Anyone good with air compressors / air systems ?
I'm racking my brain here ,I have a Craftsman 150 PSI 2cyl,7HP 60 Gallon tank compressor .It's hooked up to a Devilbis HAR602 Air control regulator .Same set up I had in NY BUT I changed one thing .I set everything up in the shop down here .The compressor is hooked up to the regulator with a 1/2 hydraulic line.I had a 3/8 line on it before .Air line hooked up to tools .When I hit the tool to operate the pressure drops like down to 10 psi.I opend up the regulator , I thought there might be a ruptured diaphragm but no.Everything seemed fine.I didn't take the canister apart though.
Could the 1/2 line be too much of a pressure drop?
I'm gonna try changing back to 3/8 line if that don't work I have a China Freight air
regulator I may try .Compressor works fine .
 

·
Registered
Joined
·
3,822 Posts
Discussion Starter · #4 ·
Run the line with the biggest inside diameter. Bypass the regulator will tell if that's the problem.
Did that already ,compressor runs fine without it .150 PSI.Coming out of compressor.
 

·
Registered
Joined
·
3,822 Posts
Discussion Starter · #5 ·
You've got something obstructing flow, and no its not the bigger line, thats the opposite of your issue.
Ok,I'm go an try and switching regulators in am .Hate to put the China Frieght on it
but oh we'll !
 

·
Previously Banned
Joined
·
10,237 Posts
I had the same issue way back when. Massive pressure drop when you asked for air. New reg solved the issue.
 
1 - 7 of 7 Posts
Top