Yellow Bullet Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1,326 Posts
Discussion Starter #1
OK Guys. Me and my buddy were just talking about the Aeromotive A1000 pump. I explained to him that prior to this I was running two Holly Blue pumps, and That I bought the A1000 to upgrade my fuel system, He stated that this pump sucks and he would not recommend it as alot of people have problems with them locking up. He also stated that he resently lost a motor due to the pump failing. I had planned on using this pump for both my carb and Nos system. Currently I have a -10 feed split with a -10 in two -10 out Y-Block to my regulators. I have a -8 return off of my carb reg. and dead head the nitrous reg. What are your opinions of this pump. I understand racers have there brands that they only use but will this system work. 600 hp NA and Im looking to spray 300 on a plate system!
 

·
Registered
Joined
·
3,606 Posts
We sell a lot of them and the only issue is when the return line is not big enough or has to many restictions the pump get hot and shortens the life of the pump
 

·
Sho'Nuff
Joined
·
5,366 Posts
We sell a lot of them and the only issue is when the return line is not big enough or has to many restictions the pump get hot and shortens the life of the pump
this. and the fact that some people never clean the filters, which cause restrictions. Some people don't even have filters and that blows my mind. The A1000 can handle what you got, you just have to install and use it right.
 

·
Registered
Joined
·
1,326 Posts
Discussion Starter #4
ok Cool. I have a 10 micron and 100 micron filter with a -8 return. is the return to small or do I need to go to -10.
 

·
Registered
Joined
·
756 Posts
never heard of a problem with a1000s. other than i need 2 of them. but i love em.
he probly didnt clean the pre filter and got something in it to lock it up.
 

·
Registered
Joined
·
1,326 Posts
Discussion Starter #8
OK Thanks guys. I feel better about my investment. How about the -8 return is that bid enough or should I go -10?
 

·
Registered
Joined
·
3,415 Posts
-10 feed -8 return is minimum recommended for carburated applications from Aeromotive for the A1000 pump,that is what I use with no issues.
 

·
Registered
Joined
·
3,606 Posts
the only issue you will have is with one pump and 1 return and 1 dead head regulator .Is that the carb pres(return reg) has to be higher than the nos pres (dead head)if you are going to spray a lot(350 OR MORE ) of nos you might have a pressure issue to the carb(to high)
 

·
Registered
Joined
·
20,824 Posts
3 Drag Weeks on mine, a lot have issues if they are running a return on the Street and they dont have much fuel in the tank or the plug filter and the fuel over heats boils and does not cool the pump it will lock up like most things its a operator error, not the pump
 

·
Registered
Joined
·
871 Posts
What about if you have a -10 feed split to 2 -8 then -6 return. Technicality the -10 acts as a reservoir for extra fuel for the 2 -8 if needs under extreme condition (306 sbf tubo maken 650 at the wheels)
 

·
Registered
Joined
·
9,494 Posts
Street miles and drag strip miles totally 1600 miles and 3 years. No problems yet. I also have the older pump that hasn't been upgraded to the new A1000. I do use the electronic device for running on the street. It changes amps or volts with RPM.
 

·
Registered
Joined
·
1,326 Posts
Discussion Starter #16
the only issue you will have is with one pump and 1 return and 1 dead head regulator .Is that the carb pres(return reg) has to be higher than the nos pres (dead head)if you are going to spray a lot(350 OR MORE ) of nos you might have a pressure issue to the carb(to high)
??? Im lost on this one... If you split the -10 feed with a -10 y block back out of the y block to regs with -10 wouldn't the nitrous reg just see constant pressure,, assuming the pump hasn't exceeded its limits.
im trying to get into the bottom 9's in street trim. I don't make close to the HP that this pump advertises. Thanks for all of the feedback guys. This makes me feel more confident about my set up.
 

·
Registered
Joined
·
557 Posts
I never had any issue with mine. It was used on and off for about 3 years. I would let it sit on the car without any maintenance/cleaning to the pump for months, then just check/clean filters and fill with gas and go. No trouble at all.
 

·
Registered
Joined
·
871 Posts
Is there a way to clean the the filters with out having to empty the tank? Or just run the tank almost dry and before you fill it back up clean the filters....


can you clean the filters or do they need to be replaced?


also is it 100 mircon before or after filter?
 

·
Registered
Joined
·
487 Posts
I ran a -10 feed to a -10 y-block to both regs, and ran a -10 return from both regs to a -10 y-block for the return, i will post pictures.





 
1 - 20 of 25 Posts
Top