Yellow Bullet Forums banner

1 - 20 of 59 Posts

·
Registered
Joined
·
662 Posts
Discussion Starter #1
Figured it was time to start my own thread. Bear with me on this first post ill try to keep them short after the story of the car is laid out.

I bought this 1979 Malibu back in 2010 before I even had a drivers license. Had a 305 with a spun rod bearing.

Heres a few pics i still had on Facebook of the day i got the car.




My dad had a splayed cap 383 engine with some cast iron bowtie heads so we put it in the car. Dynoed at 390 HP to the wheels. This was some time around 2011.

Graduated HS in 2012 and got a job as Summit Racing. so with the hook up on parts i got a Moser M9 housing for the car, redid the exhaust with some 1-7/8" to 3" Headers, magnaflow mufflers, G-force trans crossmember. This was some time around 2013 when this happened.

Took the car to the track twice and it never made a pass. Rained out first trip, second trip MSD box took a shit as soon as it came off the trailer. I got discouraged and the car has sat for the last 4 years while ive been in college. Swore up and down id never touch it again... thats turned out to be false.
 

·
Registered
Joined
·
662 Posts
Discussion Starter #2
Ive recently moved and the new house as a 24x32 garage so ive started working on the car again. For it to have sat outside for the last 4 years it has held up pretty well. It has some rust starting on the drivers side quarter but thats pretty much it.




Once in the shop we started looking over the car. We fully expected the engine to be seized up and ruined. Oil was crystal clear, no water, no discoloration. Engine had only ran 4 min since last oil change before going to the track the last time. Pulled the plugs and spun engine over. Spun freely and built oil pressure.

We ended up wiring in a new MSD box and put a fresh set of plugs in it. Car cranked before turning over a full revolution. Didnt even have to put a gasket in carb. It was like the car had waited for me.




With the car running we decided to go on and build the M9 I had laying around for the last 5 years. Dad had a 31 spline spool, 4.30 pro gear, Moser Nodular Iron center section and a MW ball bearing pinion support laying around so we slapped it all together. I also got a cheapo disc brake kit to put on the rear.



Out with the old 4.56 gear 7.5





I ordered some UPR adjustable upper and lower control arms. The uppers had to be modified to work. They have some bracing that hits the ear on rear end.



Got the car back on the ground
 

·
Registered
Joined
·
662 Posts
Discussion Starter #3
Well I didnt get post edited within 5 min time limit so heres the pics.











 

·
Registered
Joined
·
662 Posts
Discussion Starter #4 (Edited)
With the rear in the car we started doing the brakes. The car still had the original vacuum booster and MC so i got a strange manual MC to convert car to manual brakes.







Also picked up a Wilson Manifold Cross Bar plate. Way overkill for the 383 in the car but it was cheap so I couldnt pass on it.


Got a driveshaft made and installed. Went with 1350 joints and 3" DOM. Should handle anything i could afford to throw at it.


Plans down the road are to build a turbo LS. I ran across a good deal on a LC9 5.3 with a bad crankshaft this past weekend so i snagged it. Aluminum block, 243 heads, truck intake.


In my search for a crankshaft i ran accross this 06 5.3. I know its a gen 3 and the LC9 is a gen 4 but for $100 i figured i could steal the crank and sell the rest.

 

·
Registered
Joined
·
662 Posts
Discussion Starter #6
TRZ Anti roll bar came in. Itll probably sit on the shelf for a while before it gets installed.

Plans for the weekend are to finish running brake lines, bleed brakes, then work on reinstalling the seats in the car. Previous owner was a short fucker and had the seats mounted so high and close to steering wheel my 6'4" 330# ass couldnt even hardly get in the car.

Old:

https://lh3.googleusercontent.com/b3H-xayGc-A-TlAazhxp3srrzxvU5phYs3QSHxEj0hWhNxtpBNfFvUNulhehmXjqkL8oBY5NTRq7Ds1jZ6l0Xe3wXJdkdfLGABZfx0hI6LhWs96W5i8FdhpQ5YX9sjDe81NQhSIjpgNs8Njo9eozVtkiDbUDWqf8n5AatHjjPeySEpAmBsYA-iF0eyc88DSBBkg1Z9ItZmF-hbbEswOVAfYwW_9uClYkjNa_I8g6RIKSgJKxue01vQlcQ2iZx7NjGmxJWEGiIMJhu21etlOLq4Whb8UKGHiYCwhpPiSGpr44RGfyw0V_CTbvRg8rUi3kzK8Y_H9jYtXH4ymzGdU0UWg4IJop50xSj9v2q31rShmnC8L1aOH5wMktJKCy8YBfPobC6IGdY5UiTYdASHO6jgXO7NrgGJHhkilQ2r5WQ7BDefey-7kmludzV6cju_N-EMZSBRhsGBoClqzUytbHTQaiC-SkO4GK5HEaLKcf9AVOUfeRx2TTz1upqYbMj7S9xsCbQDlYr6JPOq8YvgyQGHOqNmBS_oDBgb3DpoGBhmNPa-vDhY7YTpioo9HGQioZVe6bfKGxC1fPzS4ahX0MGd2qfdFYf_6FphYr33lpPveiKmUwJBZy1NE0TfWFAjlwL0XvN-c-gnQN1Y1NV_m-gAKN=w727-h969-no

Id also like to shout out the unofficial sponsor of the build - Miller Lite


And this is how most days end up looking. To much beer drinking and not enough working


Until the weekend thats all i got. :rolleyes:
 

·
Registered
Joined
·
662 Posts
Discussion Starter #7
Spent some time in the shop yesterday, had to redo half the flares on the brake lines that were ran, and got the brakes bled.

Also tore down the $100 gen 3 5.3 i picked up last week. Was told it lost oil pressure before being pulled. All bearings look fine. Original plan was to steal crank out of it but now im probably going to put new main, rod, cam bearings in it, cam, springs, lifters and learn how to tune EFI on that engine.

 

·
Registered
Joined
·
2,417 Posts
its not often I can't see pix on yb.....but this thread is one occasion.....is anybody else not seeing the pics here?
 

·
Registered
Joined
·
662 Posts
Discussion Starter #9
its not often I can't see pix on yb.....but this thread is one occasion.....is anybody else not seeing the pics here?
I see them. Whats it look like on your end?
 

·
Registered
Joined
·
7,946 Posts
i cant see shit.

i dont understand why people use pay sites to host. you can have a private folder in facebook and dump them all there and link them straight here.
 

·
Registered
Joined
·
662 Posts
Discussion Starter #11 (Edited)
I see what the problem is. Im using google photo and can see them as im logged in on my google chrome. when i sign out photos go away.

Heres a link to all photos until i get another option set up. No wonder this thread has been so dead.
https://photos.google.com/?pageId=none

EDIT: :-damnitNevermind that doesnt work either. Mark this up as a fail
 

·
Registered
Joined
·
662 Posts
Discussion Starter #12
i cant see shit.

i dont understand why people use pay sites to host. you can have a private folder in facebook and dump them all there and link them straight here.
Ill try that. Been years since ive tried doing this on here. My Photobucket account is wiped out completely and now you gotta pay, fuck that!
 

·
Registered
Joined
·
662 Posts
Discussion Starter #13 (Edited)

·
Registered
Joined
·
662 Posts
Discussion Starter #15
much better!

looking good so far.

hat are you doing with the motor?
The 383 that's in the car currently is going to stay for now. Its a pretty nice piece and was never intended to actually be in a "race" car. Its a super light bob weight 4340 eagle crank, 6" rod, Mohle Piston bottom end with some heavily ported cast iron bowtie heads. Reed solid roller cam i cant remember specs. Came out of a sprint car. The engine runs good for what it is and is a screamer but is going to be on a short life cycle when we lay the juice to it.

Plans for the iron block Gen 3 5.3 engine is to put bearings, rings, cam, springs in it. Im going to pony up and get a Holley Dominator ECU for the car and learn how to tune with that engine. If [when] i blow it up ill only be out a few hundred bucks and wont really care.

the LC9 will get a good bottom end, leave the 243's alone, cam, possibly intake and a s475.

Now if i could find that extra $3000 i had laying around ;)
 

·
Registered
Joined
·
662 Posts
Discussion Starter #17
Well after getting all the photo shit taken care of i went out to the shop with one mission in mind...

Get at least one thing done.

Well i actually got a few done. Cleaned up the shop a bit, got the brake pedal rod adjusted, reinstalled the brake light switch and sum bitch it worked. Then while getting out of the car my pants snagged on a jagged piece of sheet metal and ripped the ass out of by dickies. :-damnit

Now its Miller Time :drinkers:
 

·
Registered
Joined
·
662 Posts
Discussion Starter #19
any chance of loading up your earlier pix? I can only see the latest set you just posted.....
What i posted was pretty much everything from the earlier posts. only ones i forgot was the pics of the car when i got it in 2010.





New Driveshaft


Heres a few from tonight

Got the brake lines finished. First time ever running all new lines on something. learned a good bit and have ideas of what to do different for the next time. but for now itll do.



Dont hate on the nasty engine bay. The Car only sat outside for the past 4 years before we moved in August.

Quick look at the inside of the Gen3 5.3. Bearings look fine for "losing oil pressure." Itll Run fine.

 

·
Registered
Joined
·
662 Posts
Discussion Starter #20
Hows everyone mounting seats in these cars? Im having to move the seat back about 4" from factory location, because im both tall and fat. Doing so the floor pans drop down 4-6". I didnt like the way they were mounted before but i cant think of another option unless i cut the floor out of the car and put flat pans back in.

Anyone got any ideas? Just spit balling here. Plans for the weekend are to at least get the drivers seat mounted, wire in line lock and destroy the 8+ year old BFG's that are on the car

This is how the short fucker i bought the car from had them Mounted.



Moving the seat back where i want it puts the rear even more in that hole for the rear seat foot room.
 
1 - 20 of 59 Posts
Top