Yellow Bullet Forums banner

7531 crank trigger signal

2017 Views 12 Replies 3 Participants Last post by  nitrousmustang
I've got a 7531 box and I'm having problems with it. I'm wondering if anyone is running a crank trigger setup besides an msd setup. I have a reichard racing crank trigger and pickup. I have no spark when I try to start the car but when I follow the diagnostic sheet to check for spark I have spark. I just got the box back from msd for repair and they said there's nothing wrong with the box. Before I sent it in the car would not idle. It acted like it was on the rev limiter under 1500 rpm but over 1500 rpm it worked fine. Anyone have any ideas? Nick
1 - 7 of 13 Posts
The wheel has an arrow and we have that correct. The sensor has the same color wires as the msd box so I just assumed they would be the same. I will have to check that. I've tried .20-.100" on the pick-up and still no spark. Maybe the box is just bad. Anyone else have any experience with this?
What is this MSD tester you speak of, delltang?

bushmec, I did their spark test and I do have spark. I believe it is a bad signal for some reason. I am going to recheck it tomorrow night after I move the pickup in some. Its at .065" now. The weird thing is that it would not idle out of the box, but it would run fine above 1500 rpm, but I guess that makes sense. According to MSD the higher the rpm the stronger the signal. I will let you guys know what I find. Check the polarity of the magnets in the pickup? MSD recommended that as well. I have to find a magnet with the poles identified on them. Thanks for the help. Nick
also you can just replace the pickup with a spare (borrowed) or purchase an extra. call manf. for the pickup you have to get polarity wire color specs. would try it at .040 check with a feeler guage. double check all specs in tree on the 7531 as well. could also be the coil, seen some weird stuff out of coil issues as of late. last look at rotor button back side. have you checked your phasing lately? at idle and at 3000. if its too far at idle it could be jumping to the term, but as soon as the advance comes in it could correct itself. just some stuff I would check.
I am going to order a new pickup tomorrow. I am going to try that. I've tried .080" to .025" with no change. The laptop is showing 165 cranking rpm. I tried a blaster 2 coil and that didn't help. I am in the habit of any time I've changed the timing to phase the rotor. It's dead nuts on. I have not looked at the back side of the rotor. I tried a different cap because I had one laying around. I don't understand why I pulled a working 6al out and now this thing won't run. Something just doesn't seem right. One really weird thing is that when I took the 7531 out we had to spin the wheel on the damper to get the timing in check with the 6al, and now that I've got the 7531 back we've had to move it back? This thing changed 25 degrees between ignition boxes, that just doesn't seem right to me. The sensor that's currently in the car is an aerospace, maybe I'll try an msd, but since the wires are color coded I'd be willing to bet they are the same sensor.
They did return it to all stock settings, but it's done this since day 1. We fired up the car for the first time in May. It did it the day we fired it up. The timing is fine, it's not pulling timing, it just doesn't send spark. I have an msd crank trigger kit that will be here tomorrow. I am going to start with the pickup. If that doesn't fix it I'm going to replace the wheel. If that doesn't fix it...I don't know. We will know more tomorrow. I appreciate your help buschmec.
Well, I'm not sure what fixed it, but it's fixed. I replaced the wiring harness from the pickup to the ignition box, and I replaced the pickup with an MSD pickup. I had an aerospace pickup. One thing I'm thinking is the guy that wired the car put a gm weatherpack connector on the pickup and the harness, I'm wondering if that had something to do with it? Anyways, we're good to go now. Thanks to everyone for your help. Nick
1 - 7 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.