Yellow Bullet Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,646 Posts
Discussion Starter #1 (Edited)
any body here using this kind of this setup?

what oil pump kit are you using & how is it working out for you?

what is the oil pressure like at idle <hot & cold>?

what oil weight are you using?

does your engine run hot now or is all good?

what modifications you had to do to use this system?

what is your experience with this setup?

any pics & input will be appreciated?

thanks
 

·
Registered
Joined
·
326 Posts
If you are Interested I'm selling a dry sump set up for a mod motor minus tank and lines
 

·
Registered
Joined
·
967 Posts
don't have any pics but I ran external oil pump wet system for awhile and worked good. oil press was around 30-40 at idle and pushing 80-90 at wot with 10w30. I have since went to daily dry sump system
 

·
Registered
Joined
·
1,646 Posts
Discussion Starter #6
don't have any pics but I ran external oil pump wet system for awhile and worked good. oil press was around 30-40 at idle and pushing 80-90 at wot with 10w30. I have since went to daily dry sump system
thanks for the reply

pardon me for asking sir:

what kind of oem oil pump DELETE /or aluminum plate did you use?

how did you prime your system?
 

·
Registered
Joined
·
3,519 Posts
thanks for the reply

pardon me for asking sir:

what kind of oem oil pump DELETE /or aluminum plate did you use?

how did you prime your system?
I know you were asking weeman, but no oil pump "delete" needed. The factory oil pump has an outlet to the side of the block...just plug the outlet. You do need a spacer where the old pump area under the left side fixed chain guide, I just cut the corner off an old stock pump. I used a Peterson wet sump, worked great. As far as priming, just take off belt and spin with a drill. If I where to do it again, I would use the Peterson oil filter mount with built in primer.
 

·
Registered
Joined
·
1,646 Posts
Discussion Starter #8
I know you were asking weeman, but no oil pump "delete" needed. The factory oil pump has an outlet to the side of the block...just plug the outlet. You do need a spacer where the old pump area under the left side fixed chain guide, I just cut the corner off an old stock pump. I used a Peterson wet sump, worked great. As far as priming, just take off belt and spin with a drill. If I where to do it again, I would use the Peterson oil filter mount with built in primer.
Thanks for the reply.

Pardon me for asking Sir;


Plug the factory oil pump feed port in the block?
You have any pics of how you did it?

No spacer or oil pump delete?

So if you DELETE the oil pump housing & did not install a spacer & you REMOVE ALL the thrust washers.

How do you control the forward & rear end play of the crank?
 

·
Registered
Joined
·
3,519 Posts
Thanks for the reply.

Pardon me for asking Sir;


Plug the factory oil pump feed port in the block?
You have any pics of how you did it?

No spacer or oil pump delete?

So if you DELETE the oil pump housing & did not install a spacer & you REMOVE ALL the thrust washers.

How do you control the forward & rear end play of the crank?
The thrust is in the rear main bearing, has nothing to do with the pump in the front. The hole you plug is the exit from the block, use the external adapter like Moroso sells, http://www.summitracing.com/parts/mor-23681/overview/make/ford
Plug the "out" and plumb your external pump to the "in" and you're done.
 

·
Registered
Joined
·
1,646 Posts
Discussion Starter #10

·
Registered
Joined
·
967 Posts
mmr roller thrust system. it has roller thrust bearings in it that also eliminates the thrust bearing issues that these mod motors tend to have
 

·
Registered
Joined
·
967 Posts
Thanks for the reply.

Pardon me for asking Sir;


Plug the factory oil pump feed port in the block?
You have any pics of how you did it?

No spacer or oil pump delete?

So if you DELETE the oil pump housing & did not install a spacer & you REMOVE ALL the thrust washers.

How do you control the forward & rear end play of the crank?
with the mmr roller thrust bearing kit that goes were the oil pump did go
 
1 - 13 of 13 Posts
Top