Yellow Bullet Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
731 Posts
Discussion Starter · #1 ·
Does anyone have a fix for the radio and windows problem in these trucks. Sometimes the radio will die and the windows won't work. I can hear what sounds like a relay click before it does it. I've changed the Accessory Delay realy but it still does it. I have looked on Powerstroke web sites and no real help for a cure. I also saw where some people say reglue the windsheild to stop any possible mositure. My problem happens all the time no matter if it has been dry for weeks or is raining out. Please help we all no you can't sell a truck if the radio doen't work.:rolleyes:
 

·
Premium Member
Joined
·
49,715 Posts
Does anyone have a fix for the radio and windows problem in these trucks. Sometimes the radio will die and the windows won't work. I can hear what sounds like a relay click before it does it. I've changed the Accessory Delay realy but it still does it. I have looked on Powerstroke web sites and no real help for a cure. I also saw where some people say reglue the windsheild to stop any possible mositure. My problem happens all the time no matter if it has been dry for weeks or is raining out. Please help we all no you can't sell a truck if the radio doen't work.:rolleyes:
Let me guess, you have clearance lights on the roof?
 

·
Registered
Joined
·
691 Posts
Southerntrendkill has a smashed up truck maybe you can get his radio :rolleyes:
 

·
Premium Member
Joined
·
49,715 Posts

·
Registered
Joined
·
153 Posts
I actually have the same problem. It is annoying as can be, especially in hotter weather when I cant get the windows down. Yes, I do have clearance lights on the roof.
 

·
Registered
Joined
·
446 Posts
Im thinking VSM (Vehicle Security Module), pretty common. Under the dash below the radio. Need the code off it to order a new one and than programmed at the dealer. Also known to throw the door ajar light on, take out alarm, dome lights, running lights, etc.
 

·
Registered
Joined
·
153 Posts
Never had any of those other issues, but probably 1/3 of the time, when i start my truck, the radio and windows won't work for several minutes. Then all of a sudden, they will both work.
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #9 · (Edited)
Wow still looking for an answer and stumbled across my old thread. No I do not have roof lights. Sometimes if I knock on the instrument panel they will start back working. When its dark outside I have noticed the order they come back on is the window switch(lil light on the switch) gets power first then the radio will come back on. I saw somewhere and cant find it now, but someone bypassed a relay and pulled power from somewhere to a new relay. After doing this they jumped from the new relay to the old relay plug in. I justdont know what relay the removed.
 

·
Registered
Joined
·
4,090 Posts
Had the same issue in my 99. I replaced the fuse/relay block under the column and it fixed everything. Bought it from Ford and it came loaded with all new fuses and relays.
 

·
Premium Member
Joined
·
49,715 Posts
leaking windshield
That's what people think.


Clearence lights leak, water runs along the top of the windshield header and down the left windshield pillar and drips onto the fuse box & GEM module. Fuse box shorts out and fries the GEM module causing all kinds of weird electrical issues from headlights that misteriously turn on to fan motors that won't turn off even with key out of ignition to dome lamp issues.


The leak in most cases will not get the floor wet. The leak is minor enough that the fuse box and GEM module soke most of it up.
 

·
Premium Member
Joined
·
49,715 Posts
Had the same issue in my 99. I replaced the fuse/relay block under the column and it fixed everything. Bought it from Ford and it came loaded with all new fuses and relays.
It will blow again. You need to fix the leak.
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #14 ·
A place near me in Greenville SC called Circuit Board Medics repairs the instrument cluster for a fix on this problem. I'm going to take the cluster out and send it to them in the next week or so. I will report back.... I don't think its the windsheild because it will do it in the summer droughts as well.
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #15 ·
**UPDATE** Circuit Board Medics fixed the problem with their standard rebuild. It was a relay on the back of the cluster. Everything works as it should now.
 
1 - 15 of 15 Posts
Top